iptables: fix libpcap static linking
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 6 Jan 2016 13:25:38 +0000 (10:25 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 2 Feb 2016 11:27:59 +0000 (12:27 +0100)
libpcap can depend on other libraries like libusb and doesn't support
pkgconfig, so add those libraries to LIBS when building statically.
Fixes:
http://autobuild.buildroot.net/results/b4a/b4a3d00e9673a7aacc663c81de1d8e887a17951d/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/iptables/iptables.mk

index 77a9fad625085aea120154d62fe3c2ec3aa0f085..12e00f23831c6e31a4d02d276414c523a52d09ea 100644 (file)
@@ -38,6 +38,11 @@ endif
 
 # bpf compiler support and nfsynproxy tool
 ifeq ($(BR2_PACKAGE_IPTABLES_BPF_NFSYNPROXY),y)
+# libpcap is tricky for static-only builds and needs help
+ifeq ($(BR2_STATIC_LIBS),y)
+IPTABLES_LIBS_FOR_STATIC_LINK += `$(STAGING_DIR)/usr/bin/pcap-config --static --additional-libs`
+IPTABLES_CONF_OPTS += LIBS="$(IPTABLES_LIBS_FOR_STATIC_LINK)"
+endif
 IPTABLES_CONF_OPTS += --enable-bpf-compiler --enable-nfsynproxy
 IPTABLES_DEPENDENCIES += libpcap
 else