Revert "cmake: bump version to 3.7.0"
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 25 Feb 2017 18:51:33 +0000 (19:51 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 26 Feb 2017 21:39:03 +0000 (22:39 +0100)
cmake 3.7 causes serious regressions in some cmake-based packages,
related to how RPATH is handled.

This reverts commit 1ffcf364b6e9894a876dc581a090f87685945412.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Cc: Samuel Martin <s.martin49@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Jörg Krause <joerg.krause@embedded.rocks>
Cc: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/cmake/Config.in
package/cmake/cmake.hash
package/cmake/cmake.mk

index 716d80ec55c28a56ff6706991ff214922826c409..6f04a4ad39eea1c89b37e9a3ac1dbb3df314bbc7 100644 (file)
@@ -20,14 +20,11 @@ config BR2_PACKAGE_CMAKE_CTEST
        select BR2_PACKAGE_EXPAT
        select BR2_PACKAGE_BZIP2
        select BR2_PACKAGE_XZ
-       select BR2_PACKAGE_LIBUV
        depends on BR2_PACKAGE_CMAKE_ARCH_SUPPORTS
        depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 # from jsoncpp
        depends on BR2_USE_WCHAR # libarchive
        depends on BR2_INSTALL_LIBSTDCPP
        depends on !BR2_STATIC_LIBS
-       depends on BR2_TOOLCHAIN_HAS_THREADS # libuv
-       depends on BR2_USE_MMU # libuv
        help
          CTest is a testing tool distributed as a part of CMake. It
          can be used to automate updating (using CVS for example),
@@ -37,9 +34,7 @@ config BR2_PACKAGE_CMAKE_CTEST
 
          http://www.cmake.org/
 
-comment "ctest needs a toolchain w/ C++, wchar, dynamic library, gcc >= 4.7, threads"
+comment "ctest needs a toolchain w/ C++, wchar, dynamic library, gcc >= 4.7"
        depends on BR2_PACKAGE_CMAKE_ARCH_SUPPORTS
-       depends on BR2_USE_MMU
        depends on !BR2_INSTALL_LIBSTDCPP || !BR2_USE_WCHAR || \
-               BR2_STATIC_LIBS || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 || \
-               !BR2_TOOLCHAIN_HAS_THREADS
+               BR2_STATIC_LIBS || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
index 687e5a448302fcd80aad7f73c33eafda7a8f3238..f846dc954147bf2b3ed5bc8501c56fadb4eb3bc7 100644 (file)
@@ -1,2 +1,2 @@
-# From http://www.cmake.org/files/v3.7/cmake-3.7.0-SHA-256.txt
-sha256 ed63e05c41aeb6c036e503114ab15847f29c312f9f21f5f1a7060a4b4ec2fb31  cmake-3.7.0.tar.gz
+# From http://www.cmake.org/files/v3.6/cmake-3.6.3-SHA-256.txt
+sha256 7d73ee4fae572eb2d7cd3feb48971aea903bb30a20ea5ae8b4da826d8ccad5fe  cmake-3.6.3.tar.gz
index e4904fcf0905678d1d49f60f805f069d5dc0a2b3..bc555092c21563a28dc714ad7b4344998694ac34 100644 (file)
@@ -4,8 +4,8 @@
 #
 ################################################################################
 
-CMAKE_VERSION_MAJOR = 3.7
-CMAKE_VERSION = $(CMAKE_VERSION_MAJOR).0
+CMAKE_VERSION_MAJOR = 3.6
+CMAKE_VERSION = $(CMAKE_VERSION_MAJOR).3
 CMAKE_SITE = https://cmake.org/files/v$(CMAKE_VERSION_MAJOR)
 CMAKE_LICENSE = BSD-3c
 CMAKE_LICENSE_FILES = Copyright.txt
@@ -22,7 +22,7 @@ CMAKE_LICENSE_FILES = Copyright.txt
 #   the system-wide libraries instead of rebuilding and statically
 #   linking with the ones bundled into the CMake sources.
 
-CMAKE_DEPENDENCIES = zlib jsoncpp libcurl libarchive expat bzip2 xz libuv
+CMAKE_DEPENDENCIES = zlib jsoncpp libcurl libarchive expat bzip2 xz
 
 CMAKE_CONF_OPTS = \
        -DKWSYS_LFS_WORKS=TRUE \