python: remove stale python2-config symbolic link
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 10 May 2013 06:29:36 +0000 (06:29 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 11 May 2013 20:41:44 +0000 (22:41 +0200)
We already remove python2.7-config and the symbolic link
python-config, but we forgot to remove the python2-config symbolic
link.

Note that we can't use the <pkg>_CONFIG_SCRIPTS mechanism here because
python2.7-config is written in... Python, and doesn't follow the usual
syntax of <pkg>-config scripts. It takes the paths directly from
distutils.sysconfig.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/python/python.mk

index b94285499484d6e286b3d1dbc69b8840433ff86d..801c6692d3d37143fa841e11493b14669a44d4d3 100644 (file)
@@ -154,6 +154,7 @@ PYTHON_POST_INSTALL_TARGET_HOOKS += PYTHON_REMOVE_SMTPD
 #
 define PYTHON_REMOVE_DEVFILES
        rm -f $(TARGET_DIR)/usr/bin/python$(PYTHON_VERSION_MAJOR)-config
+       rm -f $(TARGET_DIR)/usr/bin/python2-config
        rm -f $(TARGET_DIR)/usr/bin/python-config
 endef