zmqpp: bump git snapshot
authorSimon Dawson <spdawson@gmail.com>
Thu, 2 Jan 2014 21:54:21 +0000 (21:54 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Jan 2014 19:47:00 +0000 (20:47 +0100)
Also remove a patch which is no longer required.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/zmqpp/zmqpp-fix-typos-in-code.patch [deleted file]
package/zmqpp/zmqpp.mk

diff --git a/package/zmqpp/zmqpp-fix-typos-in-code.patch b/package/zmqpp/zmqpp-fix-typos-in-code.patch
deleted file mode 100644 (file)
index a873de9..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-Fix a couple of typos in the zmqpp source code.
-
-Signed-off-by: Simon Dawson <spdawson@gmail.com>
-
-diff -Nurp a/src/zmqpp/socket.cpp b/src/zmqpp/socket.cpp
---- a/src/zmqpp/socket.cpp     2012-12-11 11:06:23.000000000 +0000
-+++ b/src/zmqpp/socket.cpp     2013-03-18 17:32:01.464761776 +0000
-@@ -587,7 +587,7 @@ void socket::get(socket_option const& op
-       }
- }
--socket::socket(socket&& source) noexcept
-+socket::socket(socket& source) noexcept
-       : _socket(source._socket)
-       , _type(source._type)
-       , _recv_buffer()
-@@ -601,7 +601,7 @@ socket::socket(socket&& source) noexcept
-       source._socket = nullptr;
- }
--socket& socket::operator=(socket&& source) noexcept
-+socket& socket::operator=(socket& source) noexcept
- {
-       _socket = source._socket;
-       source._socket = nullptr;
-diff -Nurp a/src/zmqpp/socket.hpp b/src/zmqpp/socket.hpp
---- a/src/zmqpp/socket.hpp     2012-12-11 11:06:23.000000000 +0000
-+++ b/src/zmqpp/socket.hpp     2013-03-18 17:31:53.556790457 +0000
-@@ -400,7 +400,7 @@ public:
-        *
-        * \param source target socket to steal internals from
-        */
--      socket(socket&& source) noexcept;
-+      socket(socket& source) noexcept;
-       /*!
-        * Move operator
-@@ -413,7 +413,7 @@ public:
-        * \param source target socket to steal internals from
-        * \return socket reference to this
-        */
--      socket& operator=(socket&& source) noexcept;
-+      socket& operator=(socket& source) noexcept;
-       /*!
-        * Check the socket is still valid
index 53c58c35cd0ccc08383380da0afa23a60e3d70f2..cfd6f137523e7ffe9645f79e8a7c3a2b425d7e92 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-ZMQPP_VERSION = 31220ca4a0fb43a0848d78f5e4f23fce39945777
+ZMQPP_VERSION = 30d72d95f2cfdf9c5cedfd56747f549d65e65847
 ZMQPP_SITE = git://github.com/benjamg/zmqpp.git
 ZMQPP_INSTALL_STAGING = YES
 ZMQPP_DEPENDENCIES = zeromq