pciutils: correct dns disabling logic
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 4 Jan 2016 20:47:37 +0000 (21:47 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 4 Jan 2016 20:55:07 +0000 (21:55 +0100)
Fixes #8581

Commit 2c879f95a0 (pciutils: cleanup) refactored the make arguments, but
accidently changed the logic to disable dns based lookups to pass
PCIUTILS_DNS=no instead of DNS=no, causing the autotection to be used.

This autodetection looks at host includes, so it isn't safe for cross
compilation.

Disable it by setting the correct make variable instead.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pciutils/pciutils.mk

index 24f250eaa99ad2da7a77314aa5786726bdbaf992..d3a0e2072cd6a9f71ab58350be4a52e6c6b7e94c 100644 (file)
@@ -17,7 +17,7 @@ PCIUTILS_MAKE_OPTS = \
        LDFLAGS="$(TARGET_LDFLAGS)" \
        RANLIB=$(TARGET_RANLIB) \
        AR=$(TARGET_AR) \
-       PCIUTILS_DNS=no
+       DNS=no
 
 ifeq ($(BR2_PACKAGE_HAS_UDEV),y)
 PCIUTILS_DEPENDENCIES += udev