php: use TARGET_MAKE_ENV for buildconf
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 9 Apr 2015 01:02:16 +0000 (22:02 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 Apr 2015 09:54:48 +0000 (11:54 +0200)
Otherwise we miss the PATH for hosts that lack autotools. Fixes:
http://autobuild.buildroot.net/results/368/368da962f657801817a4b962415e55606915c871/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/php/php.mk

index eb4f79749fa9d4b703ff7d33d67a97d30394795c..f3556327ab07e79fe11e2100debe5a116ba6497e 100644 (file)
@@ -25,7 +25,7 @@ PHP_CONF_ENV = EXTRA_LIBS="$(PHP_EXTRA_LIBS)"
 # PHP can't be AUTORECONFed the standard way unfortunately
 PHP_DEPENDENCIES += host-autoconf host-automake host-libtool
 define PHP_BUILDCONF
-       cd $(@D) ; ./buildconf --force
+       cd $(@D) ; $(TARGET_MAKE_ENV) ./buildconf --force
 endef
 PHP_PRE_CONFIGURE_HOOKS += PHP_BUILDCONF