erlang-p1-stringprep: bump to version 1.0.0
authorFrank Hunleth <fhunleth@troodon-software.com>
Tue, 2 Feb 2016 19:57:35 +0000 (14:57 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 20 Feb 2016 17:51:16 +0000 (18:51 +0100)
This version includes C++ code, so also add dependency on a C++
compiler.

Signed-off-by: Frank Hunleth <fhunleth@troodon-software.com>
[Thomas:
 - propagate new C++ dependency to ejabberd, as noticed by
   Romain Naour
 - fix license information and license files. Not all the code is
   under the TCL license, in fact most of the code is under the
   Apache-2.0 license, and some additional license files have been
   added to clarify this.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ejabberd/Config.in
package/erlang-p1-stringprep/Config.in
package/erlang-p1-stringprep/erlang-p1-stringprep.mk

index 7b4e99b7917a14ec3627f6ef0d8af75d903d828e..5d176c3af632de8a4328d409c703eec5daa5d42f 100644 (file)
@@ -1,6 +1,7 @@
 config BR2_PACKAGE_EJABBERD
        bool "ejabberd"
        depends on BR2_PACKAGE_ERLANG
+       depends on BR2_INSTALL_LIBSTDCPP # stringprep
        select BR2_PACKAGE_ERLANG_LAGER
        select BR2_PACKAGE_ERLANG_P1_CACHE_TAB
        select BR2_PACKAGE_ERLANG_P1_ICONV
@@ -18,5 +19,5 @@ config BR2_PACKAGE_EJABBERD
 
          http://www.ejabberd.im
 
-comment "ejabberd needs erlang"
-       depends on !BR2_PACKAGE_ERLANG
+comment "ejabberd needs erlang, toolchain w/ C++"
+       depends on !BR2_PACKAGE_ERLANG || !BR2_INSTALL_LIBSTDCPP
index 3ef77ed60145847bcbb7a78f4bbcdcf727ddb79e..bc4d1394ef72a5100121dee92b65dda320fac85e 100644 (file)
@@ -1,5 +1,9 @@
+comment "erlang-p1-stringprep needs a toolchain w/ C++"
+       depends on !BR2_INSTALL_LIBSTDCPP
+
 config BR2_PACKAGE_ERLANG_P1_STRINGPREP
        bool "erlang-p1-stringprep"
+       depends on BR2_INSTALL_LIBSTDCPP
        help
          Erlang interface to stringprep
 
index 60c80bc06ebd038d4afb6a455113d464fcdc52a9..0a5a1f548ddbd12b7c1e227198e3630f3b1401c0 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-ERLANG_P1_STRINGPREP_VERSION = 3c64023
+ERLANG_P1_STRINGPREP_VERSION = 1.0.0
 ERLANG_P1_STRINGPREP_SITE = $(call github,processone,stringprep,$(ERLANG_P1_STRINGPREP_VERSION))
-ERLANG_P1_STRINGPREP_LICENSE = TCL
-ERLANG_P1_STRINGPREP_LICENSE_FILES = LICENSE.TCL
+ERLANG_P1_STRINGPREP_LICENSE = TCL (tools/*.tcl), Apache-2.0 (rest)
+ERLANG_P1_STRINGPREP_LICENSE_FILES = LICENSE.ALL LICENSE.TCL LICENSE.txt
 
 $(eval $(rebar-package))