core: override the user's locale while setting HOSTARCH
authorRomain Naour <romain.naour@gmail.com>
Wed, 20 Jan 2016 21:53:19 +0000 (22:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 20 Jan 2016 22:00:01 +0000 (23:00 +0100)
At least with French user's locale HOSTARCH is empty since
'Target' is not present in gcc output.

gcc -v 2>&1
Utilisation des specs internes.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/libexec/gcc/x86_64-redhat-linux/5.3.1/lto-wrapper
Cible : x86_64-redhat-linux

Override the user's local with LC_ALL=C.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index 2e09611af26164efa15da5b43b84034a279c7f8e..17c181bba1e23515a1405d04a07c65bbc562c700 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -297,7 +297,7 @@ export HOSTCC_NOCCACHE HOSTCXX_NOCCACHE
 # So, we extract the first part of the tuple the host gcc was
 # configured to generate code for; we assume this is our userland.
 #
-export HOSTARCH := $(shell $(HOSTCC_NOCCACHE) -v 2>&1 | \
+export HOSTARCH := $(shell LC_ALL=C $(HOSTCC_NOCCACHE) -v 2>&1 | \
        sed -e '/^Target: \([^-]*\).*/!d' \
            -e 's//\1/' \
            -e 's/i.86/x86/' \