package/util-linux: disable systemd for host build
authorJohn Keeping <john@metanate.com>
Wed, 19 Feb 2020 11:25:59 +0000 (11:25 +0000)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 26 Feb 2020 21:35:43 +0000 (22:35 +0100)
When building host-util-linux, the systemdsystemunitdir is set to the
real host directory, so the install step fails with:

/usr/bin/install: cannot remove '/usr/lib/systemd/system/fstrim.service': Permission denied
/usr/bin/install: cannot remove '/usr/lib/systemd/system/fstrim.timer': Permission denied

Since we don't need systemd support in host-util-linux, unconditionally
disable it for the host build.

Signed-off-by: John Keeping <john@metanate.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/util-linux/util-linux.mk

index 549442232eec868154ec0ef7832de7d4204569c1..b6ccaaa78d926edd069bdb133fc31bccc1d18b2a 100644 (file)
@@ -38,7 +38,10 @@ UTIL_LINUX_CONF_OPTS += \
 HOST_UTIL_LINUX_DEPENDENCIES = host-pkgconf
 
 # We also don't want the host-python dependency
-HOST_UTIL_LINUX_CONF_OPTS = --without-python
+HOST_UTIL_LINUX_CONF_OPTS = \
+       --without-systemd \
+       --with-systemdsystemunitdir=no \
+       --without-python
 
 # Prevent the installation from attempting to move shared libraries from
 # ${usrlib_execdir} (/usr/lib) to ${libdir} (/lib), since both paths are