package/pkg-luarocks: drop flock at installation time
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 19 Nov 2018 10:32:26 +0000 (11:32 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 19 Nov 2018 20:43:34 +0000 (21:43 +0100)
In commit 22b327fc743b48a33aec0a9190bd67118641b294 ("pkg-luarocks: fix
top-level parallel makefile support"), a flock on $(TARGET_DIR) was
added to ensure that two Luarocks packages are not installed at the
same time.

However, to support top-level parallel build, we have now clearly
decided that per-package folders is a requirement. Therefore,
TARGET_DIR is anyway going to be different for each package, making
this flock unnecessary.

Trying to use top-level parallel build without per-package folder is
simply not supported, so this commit drops the unnecessary flock.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
package/pkg-luarocks.mk

index 29c5e66cd1a10c1a64099a598785d45bf00f34fb..f0985433b76d334a71d932cd8833c4f91271afab 100644 (file)
@@ -63,7 +63,7 @@ endif
 #
 ifndef $(2)_INSTALL_TARGET_CMDS
 define $(2)_INSTALL_TARGET_CMDS
-       cd $$($(2)_SRCDIR) && $$(LUAROCKS_RUN_ENV) flock $$(TARGET_DIR) \
+       cd $$($(2)_SRCDIR) && $$(LUAROCKS_RUN_ENV) \
                $$(LUAROCKS_RUN_CMD) make --keep $$($(2)_ROCKSPEC) $$($(2)_BUILD_OPTS)
 endef
 endif