package/systemd: add optional support for tmpfiles
authorGabe Evans <gabe@hashrabbit.co>
Fri, 1 Jul 2016 21:51:01 +0000 (23:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jul 2016 10:26:54 +0000 (12:26 +0200)
Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
[Maxime: Add default y]
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/Config.in
package/systemd/systemd.mk

index 324e8844894490fb0f4de66f58d3e861acc46385..df1a428940229f48f3a800fe1b86e549814d42a4 100644 (file)
@@ -131,6 +131,17 @@ config BR2_PACKAGE_SYSTEMD_QUOTACHECK
 
          http://www.freedesktop.org/software/systemd/man/systemd-quotacheck.service.html
 
+config BR2_PACKAGE_SYSTEMD_TMPFILES
+       bool "enable tmpfiles support"
+       default y
+       help
+         systemd-tmpfiles creates, deletes, and cleans up volatile
+         and temporary files and directories, based on the
+         configuration file format and location specified in
+         tmpfiles.d(5).
+
+         http://www.freedesktop.org/software/systemd/man/systemd-tmpfiles.html
+
 config BR2_PACKAGE_SYSTEMD_NETWORKD
        bool "enable network manager"
        help
index c0503ae921b050e82c0feeebe1bd7c358356645d..779d7c51e132fa9bc8b20fd2519be7e880e23b9b 100644 (file)
@@ -159,6 +159,12 @@ else
 SYSTEMD_CONF_OPTS += --disable-quotacheck
 endif
 
+ifeq ($(BR2_PACKAGE_SYSTEMD_TMPFILES),y)
+SYSTEMD_CONF_OPTS += --enable-tmpfiles
+else
+SYSTEMD_CONF_OPTS += --disable-tmpfiles
+endif
+
 ifeq ($(BR2_PACKAGE_SYSTEMD_NETWORKD),y)
 SYSTEMD_CONF_OPTS += --enable-networkd
 define SYSTEMD_INSTALL_RESOLVCONF_HOOK