gnutls: remove manual tools disabling kludge
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 14 Dec 2015 18:41:38 +0000 (15:41 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 15 Dec 2015 20:51:13 +0000 (21:51 +0100)
It's no longer required, tools are guarded by ENABLE_TOOLS in
Makefile.am and excluded accordingly.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gnutls/gnutls.mk

index 2855e8f4fd293875eeaad446b3464c4361639b33..0ab521e916d1fbbe33133d4323fd348fec96f73f 100644 (file)
@@ -20,7 +20,8 @@ GNUTLS_CONF_OPTS = \
        --enable-openssl-compatibility \
        --with-libnettle-prefix=$(STAGING_DIR)/usr \
        --with-librt-prefix=$(STAGING_DIR) \
-       --without-tpm
+       --without-tpm \
+       $(if $(BR2_PACKAGE_GNUTLS_TOOLS),--enable-tools,--disable-tools)
 GNUTLS_CONF_ENV = gl_cv_socket_ipv6=yes \
        ac_cv_header_wchar_h=$(if $(BR2_USE_WCHAR),yes,no) \
        gt_cv_c_wchar_t=$(if $(BR2_USE_WCHAR),yes,no) \
@@ -80,11 +81,4 @@ else
 GNUTLS_CONF_OPTS += --without-zlib
 endif
 
-define GNUTLS_DISABLE_TOOLS
-       $(SED) 's/\$$(PROGRAMS)//' $(@D)/src/Makefile.in
-       $(SED) 's/) install-exec-am/)/' $(@D)/src/Makefile.in
-endef
-
-GNUTLS_POST_PATCH_HOOKS += $(if $(BR2_PACKAGE_GNUTLS_TOOLS),,GNUTLS_DISABLE_TOOLS)
-
 $(eval $(autotools-package))