gcc: don't patch gcc if there are no patches to apply
authorMischa Jonker <mischa.jonker@synopsys.com>
Mon, 11 Nov 2013 14:36:36 +0000 (15:36 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 11 Nov 2013 21:44:08 +0000 (22:44 +0100)
While the generic package handler checks for a directory with patches
before starting apply-patches.sh, this is not the case for gcc: the
script is called, even if there is no directory with patches. This results
into a build failure, as apply-patches exits with error code 1 if the
directory doesn't exist.

Signed-off-by: Mischa Jonker <mjonker@synopsys.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/gcc/gcc.mk

index 0c0cc99a6104f92fe0b7990f442f2df333e7ee51..41600ef6ecdb8d250b66db3d20582dc3837cef48 100644 (file)
@@ -49,7 +49,9 @@ endif
 endif
 
 define HOST_GCC_APPLY_PATCHES
-       support/scripts/apply-patches.sh $(@D) package/gcc/$(GCC_VERSION) \*.patch
+       if test -d package/gcc/$(GCC_VERSION); then \
+         support/scripts/apply-patches.sh $(@D) package/gcc/$(GCC_VERSION) \*.patch ; \
+       fi;
        $(HOST_GCC_APPLY_POWERPC_PATCH)
 endef