package/lua: bump to version 5.3.6
authorFrancois Perrad <fperrad@gmail.com>
Fri, 25 Sep 2020 18:17:17 +0000 (20:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Sep 2020 13:42:51 +0000 (15:42 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lua/5.3.5/0001-root-path.patch [deleted file]
package/lua/5.3.5/0002-shared-libs-for-lua.patch [deleted file]
package/lua/5.3.5/0003-fix-revision-number.patch [deleted file]
package/lua/5.3.5/0011-linenoise.patch [deleted file]
package/lua/5.3.6/0001-root-path.patch [new file with mode: 0644]
package/lua/5.3.6/0002-shared-libs-for-lua.patch [new file with mode: 0644]
package/lua/5.3.6/0003-linenoise.patch [new file with mode: 0644]
package/lua/lua.hash
package/lua/lua.mk

diff --git a/package/lua/5.3.5/0001-root-path.patch b/package/lua/5.3.5/0001-root-path.patch
deleted file mode 100644 (file)
index a44c55c..0000000
+++ /dev/null
@@ -1,17 +0,0 @@
-Adjust installation location to /usr.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/src/luaconf.h
-===================================================================
---- a/src/luaconf.h
-+++ b/src/luaconf.h
-@@ -200,7 +200,7 @@
-
- #else                 /* }{ */
-
--#define LUA_ROOT      "/usr/local/"
-+#define LUA_ROOT      "/usr/"
- #define LUA_LDIR      LUA_ROOT "share/lua/" LUA_VDIR "/"
- #define LUA_CDIR      LUA_ROOT "lib/lua/" LUA_VDIR "/"
- #define LUA_PATH_DEFAULT  \
diff --git a/package/lua/5.3.5/0002-shared-libs-for-lua.patch b/package/lua/5.3.5/0002-shared-libs-for-lua.patch
deleted file mode 100644 (file)
index 493828c..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-Add the compilation of a shared library.
-Compile the lua binary with the shared library.
-And install the shared library.
-The variable BUILDMODE allows to switch between static and dynamic mode.
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/Makefile
-===================================================================
---- a/Makefile
-+++ b/Makefile
-@@ -42,6 +42,7 @@
- TO_BIN= lua luac
- TO_INC= lua.h luaconf.h lualib.h lauxlib.h lua.hpp
- TO_LIB= liblua.a
-+TO_SOLIB = liblua.so.$(R)
- TO_MAN= lua.1 luac.1
- # Lua version and release.
-@@ -60,6 +61,8 @@
- install: dummy
-       cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
-       cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
-+      test -f src/$(TO_SOLIB) && cd src && $(INSTALL_EXEC) $(TO_SOLIB) $(INSTALL_LIB) || :
-+      test -f src/$(TO_SOLIB) && ln -sf $(TO_SOLIB) $(INSTALL_LIB)/liblua.so || :
-       cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
-       cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
-       cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
-Index: b/src/Makefile
-===================================================================
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -29,6 +29,7 @@
- PLATS= aix bsd c89 freebsd generic linux macosx mingw posix solaris
- LUA_A=        liblua.a
-+LUA_SO=       liblua.so
- CORE_O=       lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
-       lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
-       ltm.o lundump.o lvm.o lzio.o
-@@ -43,8 +44,13 @@
- LUAC_O=       luac.o
- ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
-+ifneq (dynamic,$(BUILDMODE))
- ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
-+else
-+ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
-+endif
- ALL_A= $(LUA_A)
-+ALL_SO= $(LUA_SO)
- # Targets start here.
- default: $(PLAT)
-@@ -55,12 +61,23 @@
- a:    $(ALL_A)
-+so:   $(ALL_SO)
-+
- $(LUA_A): $(BASE_O)
-       $(AR) $@ $(BASE_O)
-       $(RANLIB) $@
-+$(LUA_SO): $(CORE_O) $(LIB_O)
-+      $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
-+      ln -fs $@.$(PKG_VERSION) $@
-+
-+ifneq (dynamic,$(BUILDMODE))
- $(LUA_T): $(LUA_O) $(LUA_A)
-       $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
-+else
-+$(LUA_T): $(LUA_O) $(LUA_SO)
-+      $(CC) -o $@ -L. $(LDFLAGS) $(LUA_O) -llua $(LIBS)
-+endif
- $(LUAC_T): $(LUAC_O) $(LUA_A)
-       $(CC) -o $@ $(LDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
diff --git a/package/lua/5.3.5/0003-fix-revision-number.patch b/package/lua/5.3.5/0003-fix-revision-number.patch
deleted file mode 100644 (file)
index ed2e046..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-Fix revision number
-
-In 0002-shared-libs-for-lua.patch, revision number is used to set 
-library name:
-TO_SOLIB = liblua.so.$(R)
-
-However, library is built using PKG_VERSION which is passed only during
-build step:
-$(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
-
-As a result, dynamic library is not installed in staging or target paths
-since bump to lua 5.3.5
-
-So, instead of replacing R by PKG_VERSION and passing this variable in
-all steps, simply update R to 5
-
-Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
-
-Index: b/Makefile
-===================================================================
---- a/Makefile
-+++ b/Makefile
-@@ -47,6 +47,6 @@
-
- # Lua version and release.
- V= 5.3
--R= $V.4
-+R= $V.5
-
- # Targets start here.
- all:    $(PLAT)
diff --git a/package/lua/5.3.5/0011-linenoise.patch b/package/lua/5.3.5/0011-linenoise.patch
deleted file mode 100644 (file)
index 574e6c8..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-Add support of linenoise (replace readline)
-
-see discussion, http://lua-users.org/lists/lua-l/2010-03/msg00879.html
-
-Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
-
-Index: b/src/lua.c
-===================================================================
---- a/src/lua.c
-+++ b/src/lua.c
-@@ -85,6 +85,13 @@
- #define lua_saveline(L,line)  ((void)L, add_history(line))
- #define lua_freeline(L,b)     ((void)L, free(b))
-+#elif defined(LUA_USE_LINENOISE)
-+
-+#include <linenoise.h>
-+#define lua_readline(L,b,p)   ((void)L, ((b)=linenoise(p)) != NULL)
-+#define lua_saveline(L,line)  ((void)L, linenoiseHistoryAdd(line))
-+#define lua_freeline(L,b)     ((void)L, free(b))
-+
- #else                         /* }{ */
- #define lua_readline(L,b,p) \
diff --git a/package/lua/5.3.6/0001-root-path.patch b/package/lua/5.3.6/0001-root-path.patch
new file mode 100644 (file)
index 0000000..a44c55c
--- /dev/null
@@ -0,0 +1,17 @@
+Adjust installation location to /usr.
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/src/luaconf.h
+===================================================================
+--- a/src/luaconf.h
++++ b/src/luaconf.h
+@@ -200,7 +200,7 @@
+
+ #else                 /* }{ */
+
+-#define LUA_ROOT      "/usr/local/"
++#define LUA_ROOT      "/usr/"
+ #define LUA_LDIR      LUA_ROOT "share/lua/" LUA_VDIR "/"
+ #define LUA_CDIR      LUA_ROOT "lib/lua/" LUA_VDIR "/"
+ #define LUA_PATH_DEFAULT  \
diff --git a/package/lua/5.3.6/0002-shared-libs-for-lua.patch b/package/lua/5.3.6/0002-shared-libs-for-lua.patch
new file mode 100644 (file)
index 0000000..493828c
--- /dev/null
@@ -0,0 +1,78 @@
+Add the compilation of a shared library.
+Compile the lua binary with the shared library.
+And install the shared library.
+The variable BUILDMODE allows to switch between static and dynamic mode.
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/Makefile
+===================================================================
+--- a/Makefile
++++ b/Makefile
+@@ -42,6 +42,7 @@
+ TO_BIN= lua luac
+ TO_INC= lua.h luaconf.h lualib.h lauxlib.h lua.hpp
+ TO_LIB= liblua.a
++TO_SOLIB = liblua.so.$(R)
+ TO_MAN= lua.1 luac.1
+ # Lua version and release.
+@@ -60,6 +61,8 @@
+ install: dummy
+       cd src && $(MKDIR) $(INSTALL_BIN) $(INSTALL_INC) $(INSTALL_LIB) $(INSTALL_MAN) $(INSTALL_LMOD) $(INSTALL_CMOD)
+       cd src && $(INSTALL_EXEC) $(TO_BIN) $(INSTALL_BIN)
++      test -f src/$(TO_SOLIB) && cd src && $(INSTALL_EXEC) $(TO_SOLIB) $(INSTALL_LIB) || :
++      test -f src/$(TO_SOLIB) && ln -sf $(TO_SOLIB) $(INSTALL_LIB)/liblua.so || :
+       cd src && $(INSTALL_DATA) $(TO_INC) $(INSTALL_INC)
+       cd src && $(INSTALL_DATA) $(TO_LIB) $(INSTALL_LIB)
+       cd doc && $(INSTALL_DATA) $(TO_MAN) $(INSTALL_MAN)
+Index: b/src/Makefile
+===================================================================
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -29,6 +29,7 @@
+ PLATS= aix bsd c89 freebsd generic linux macosx mingw posix solaris
+ LUA_A=        liblua.a
++LUA_SO=       liblua.so
+ CORE_O=       lapi.o lcode.o lctype.o ldebug.o ldo.o ldump.o lfunc.o lgc.o llex.o \
+       lmem.o lobject.o lopcodes.o lparser.o lstate.o lstring.o ltable.o \
+       ltm.o lundump.o lvm.o lzio.o
+@@ -43,8 +44,13 @@
+ LUAC_O=       luac.o
+ ALL_O= $(BASE_O) $(LUA_O) $(LUAC_O)
++ifneq (dynamic,$(BUILDMODE))
+ ALL_T= $(LUA_A) $(LUA_T) $(LUAC_T)
++else
++ALL_T= $(LUA_A) $(LUA_SO) $(LUA_T) $(LUAC_T)
++endif
+ ALL_A= $(LUA_A)
++ALL_SO= $(LUA_SO)
+ # Targets start here.
+ default: $(PLAT)
+@@ -55,12 +61,23 @@
+ a:    $(ALL_A)
++so:   $(ALL_SO)
++
+ $(LUA_A): $(BASE_O)
+       $(AR) $@ $(BASE_O)
+       $(RANLIB) $@
++$(LUA_SO): $(CORE_O) $(LIB_O)
++      $(CC) -o $@.$(PKG_VERSION) -shared -Wl,-soname="$@.$(PKG_VERSION)" $?
++      ln -fs $@.$(PKG_VERSION) $@
++
++ifneq (dynamic,$(BUILDMODE))
+ $(LUA_T): $(LUA_O) $(LUA_A)
+       $(CC) -o $@ $(LDFLAGS) $(LUA_O) $(LUA_A) $(LIBS)
++else
++$(LUA_T): $(LUA_O) $(LUA_SO)
++      $(CC) -o $@ -L. $(LDFLAGS) $(LUA_O) -llua $(LIBS)
++endif
+ $(LUAC_T): $(LUAC_O) $(LUA_A)
+       $(CC) -o $@ $(LDFLAGS) $(LUAC_O) $(LUA_A) $(LIBS)
diff --git a/package/lua/5.3.6/0003-linenoise.patch b/package/lua/5.3.6/0003-linenoise.patch
new file mode 100644 (file)
index 0000000..574e6c8
--- /dev/null
@@ -0,0 +1,24 @@
+Add support of linenoise (replace readline)
+
+see discussion, http://lua-users.org/lists/lua-l/2010-03/msg00879.html
+
+Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
+
+Index: b/src/lua.c
+===================================================================
+--- a/src/lua.c
++++ b/src/lua.c
+@@ -85,6 +85,13 @@
+ #define lua_saveline(L,line)  ((void)L, add_history(line))
+ #define lua_freeline(L,b)     ((void)L, free(b))
++#elif defined(LUA_USE_LINENOISE)
++
++#include <linenoise.h>
++#define lua_readline(L,b,p)   ((void)L, ((b)=linenoise(p)) != NULL)
++#define lua_saveline(L,line)  ((void)L, linenoiseHistoryAdd(line))
++#define lua_freeline(L,b)     ((void)L, free(b))
++
+ #else                         /* }{ */
+ #define lua_readline(L,b,p) \
index ab72480e552aeb440c55fd12ecdf8bf3356a7381..5ace44458f3bbe877fec3fb0824960cbdfa35313 100644 (file)
@@ -2,10 +2,11 @@
 md5 dbf155764e5d433fc55ae80ea7060b60           lua-5.4.0.tar.gz
 sha1 8cdbffa8a214a23d190d7c45f38c19518ae62e89  lua-5.4.0.tar.gz
 
-md5 4f4b4f323fd3514a68e0ab3da8ce3455           lua-5.3.5.tar.gz
-sha1 112eb10ff04d1b4c9898e121d6bdf54a81482447  lua-5.3.5.tar.gz
+md5 83f23dbd5230140a3770d5f54076948d           lua-5.3.6.tar.gz
+sha1 f27d20d6c81292149bc4308525a9d6733c224fa5  lua-5.3.6.tar.gz
 
 md5 2e115fe26e435e33b0d5c022e4490567           lua-5.1.5.tar.gz
 sha1 b3882111ad02ecc6b972f8c1241647905cb2e3fc  lua-5.1.5.tar.gz
+
 # Locally computed
 sha256  ee5e3e82af1e1b543c4f216e399d7c8cfee797711913f349e385101c4ae60a79  COPYRIGHT
index ee604b612124a5dd1400b80393ffaab9f1fe28f7..9ff738656d9d457d7c46c43e8c97d723ccda13dc 100644 (file)
@@ -7,7 +7,7 @@
 ifeq ($(BR2_PACKAGE_LUA_5_4),y)
 LUA_VERSION = 5.4.0
 else ifeq ($(BR2_PACKAGE_LUA_5_3),y)
-LUA_VERSION = 5.3.5
+LUA_VERSION = 5.3.6
 else
 LUA_VERSION = 5.1.5
 endif