package/lftp: Add optional support for libidn
authorMario Lang <mlang@blind.guru>
Tue, 28 Nov 2017 12:10:12 +0000 (13:10 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 29 Nov 2017 20:33:37 +0000 (21:33 +0100)
Signed-off-by: Mario Lang <mlang@blind.guru>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lftp/lftp.mk

index de4ebb85217d75bd8016e9bca4df9c468979ea04..b174057f03f6a82f92b3fb66b65ea93b9fd12374 100644 (file)
@@ -41,6 +41,13 @@ else
 LFTP_CONF_OPTS += --without-openssl
 endif
 
+ifeq ($(BR2_PACKAGE_LIBIDN),y)
+LFTP_DEPENDENCIES += libidn
+LFTP_CONF_OPTS += --with-libidn=$(STAGING_DIR)/usr
+else
+LFTP_CONF_OPTS += --without-libidn
+endif
+
 # Remove /usr/share/lftp
 define LFTP_REMOVE_DATA
        $(RM) -fr $(TARGET_DIR)/usr/share/lftp