package/go: Add HOST_GO_TARGET_ENV
authorGeoff Levand <geoff@infradead.org>
Thu, 26 May 2016 18:21:32 +0000 (18:21 +0000)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 26 May 2016 19:04:24 +0000 (21:04 +0200)
For the convenience of package makefiles define the new
make variables HOST_GO_TOOLDIR and HOST_GO_TARGET_ENV.

Signed-off-by: Geoff Levand <geoff@infradead.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/go/go.mk

index 7ac2540b91762d0cbe0baa0c2436b070d70d1762..090c5e4f1c26f6b258df5d3f3d85d4443d78a0e8 100644 (file)
@@ -35,6 +35,15 @@ endif
 HOST_GO_DEPENDENCIES = host-go-bootstrap
 HOST_GO_ROOT = $(HOST_DIR)/usr/lib/go
 
+# For the convienience of target packages.
+HOST_GO_TOOLDIR = $(HOST_GO_ROOT)/pkg/tool/linux_$(GO_GOARCH)
+HOST_GO_TARGET_ENV = \
+       GOARCH=$(GO_GOARCH) \
+       GOROOT="$(HOST_GO_ROOT)" \
+       CC=$(TARGET_CC) \
+       CXX=$(TARGET_CXX) \
+       GOTOOLDIR="$(HOST_GO_TOOLDIR)"
+
 # The go build system doesn't have the notion of cross compiling, but just the
 # notion of architecture.  When the host and target architectures are different
 # it expects to be given a target cross compiler in CC_FOR_TARGET.  When the