package/micropython: require python3 on the host
authorChris Packham <judge.packham@gmail.com>
Sun, 20 Oct 2019 08:28:08 +0000 (21:28 +1300)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 26 Oct 2019 10:34:50 +0000 (12:34 +0200)
There are some scripts used when building micropython that require
python3 on the build host. Use BR2_PYTHON3_HOST_DEPENDENCY so this can
be either be satisfied by installing it on the build host or by building
the host-python3 package.

Fixes:
- http://autobuild.buildroot.net/results/b85b2214576030026a8e04d142a77a2648379417/

Signed-off-by: Chris Packham <judge.packham@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/micropython/micropython.mk

index 5824b4ab182fe674b37c70d9b7efe2fe3bd5d36d..a5b8218d1f66f64ca5c8ae8f75223e7b26731ad1 100644 (file)
@@ -8,7 +8,7 @@ MICROPYTHON_VERSION = 1.11
 MICROPYTHON_SITE = $(call github,micropython,micropython,v$(MICROPYTHON_VERSION))
 MICROPYTHON_LICENSE = MIT
 MICROPYTHON_LICENSE_FILES = LICENSE
-MICROPYTHON_DEPENDENCIES = host-pkgconf libffi
+MICROPYTHON_DEPENDENCIES = host-pkgconf libffi $(BR2_PYTHON3_HOST_DEPENDENCY)
 
 # Set GIT_DIR so package won't use buildroot's version number
 MICROPYTHON_MAKE_ENV = \