gnupg2: don't preserve the old gpg2 executable name
authorBaruch Siach <baruch@tkos.co.il>
Tue, 14 Nov 2017 12:02:38 +0000 (14:02 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 27 Nov 2017 20:52:13 +0000 (21:52 +0100)
Commit e82fadab236a (gnupg2: bump to version 2.2.0) added a configure
option to keep the old 'gpg2' executable name to avoid conflict with the
gnupg package. It turns out that gnupg depends on !BR2_PACKAGE_GNUPG2
since commit 2cadb26e6d4 (gnupg: make gnupg and gnupg2 mutually
exclusive). Drop this configure option.

Rename the config option that controls the removal of gpgv2, now gpgv,
to match the new name. Add legacy config symbol handling.

Cc: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/gnupg2/Config.in
package/gnupg2/gnupg2.mk

index 35a6d6e1fe7405980161ab472af16fbd71c62ce5..c8db9fac42e9c74573efe22e6149a4404b44046c 100644 (file)
@@ -142,6 +142,17 @@ comment "build, or run, in unpredictable ways.               "
 comment "----------------------------------------------------"
 endif
 
+###############################################################################
+comment "Legacy options removed in 2018.02"
+
+config BR2_PACKAGE_GNUPG2_GPGV2
+       bool "gnupg2 gpgv2 option removed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_GNUPG2_GPGV
+       help
+         The gpgv2 executable is now named gpgv. The config option
+         has been renamed accordingly.
+
 ###############################################################################
 comment "Legacy options removed in 2017.11"
 
index c287089657802226cbaf7fe7e56103e24bbf0b79..ef1817ef02dc1c27284ea67b11319a5ad0fb7d48 100644 (file)
@@ -28,10 +28,10 @@ config BR2_PACKAGE_GNUPG2
 
 if BR2_PACKAGE_GNUPG2
 
-config BR2_PACKAGE_GNUPG2_GPGV2
-       bool "gpgv2"
+config BR2_PACKAGE_GNUPG2_GPGV
+       bool "gpgv"
        help
-         gpgv2 is an OpenPGP signature verification tool.
+         gpgv is an OpenPGP signature verification tool.
 
          This program is actually a stripped-down version of gpg
          which is only able to check signatures. It is somewhat
index 0466ed633f25c40c3b9177bf36327d50747dd624..f5fcb15e369b4b38e0c7251e8f66b22c82870914 100644 (file)
@@ -12,9 +12,7 @@ GNUPG2_LICENSE_FILES = COPYING
 GNUPG2_DEPENDENCIES = zlib libgpg-error libgcrypt libassuan libksba libnpth \
        $(if $(BR2_PACKAGE_LIBICONV),libiconv) host-pkgconf
 
-# Keep the gpg2 binary name to avoid conflict with gnupg
 GNUPG2_CONF_OPTS = \
-       --enable-gpg-is-gpg2 \
        --disable-rpath --disable-regex --disable-doc \
        --with-libgpg-error-prefix=$(STAGING_DIR)/usr \
        --with-libgcrypt-prefix=$(STAGING_DIR)/usr \
@@ -22,11 +20,11 @@ GNUPG2_CONF_OPTS = \
        --with-ksba-prefix=$(STAGING_DIR)/usr \
        --with-npth-prefix=$(STAGING_DIR)/usr
 
-ifneq ($(BR2_PACKAGE_GNUPG2_GPGV2),y)
-define GNUPG2_REMOVE_GPGV2
-       rm -f $(TARGET_DIR)/usr/bin/gpgv2
+ifneq ($(BR2_PACKAGE_GNUPG2_GPGV),y)
+define GNUPG2_REMOVE_GPGV
+       rm -f $(TARGET_DIR)/usr/bin/gpgv
 endef
-GNUPG2_POST_INSTALL_TARGET_HOOKS += GNUPG2_REMOVE_GPGV2
+GNUPG2_POST_INSTALL_TARGET_HOOKS += GNUPG2_REMOVE_GPGV
 endif
 
 ifeq ($(BR2_PACKAGE_BZIP2),y)