package/ltp-testsuite: fix build with musl-fts
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 11 Oct 2019 17:15:47 +0000 (19:15 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Fri, 11 Oct 2019 20:09:52 +0000 (22:09 +0200)
Fixes:
 - http://autobuild.buildroot.org/results/7a4b54768584b2ec95f7f5c0932d0161ab8e43d5

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/ltp-testsuite/Config.in
package/ltp-testsuite/ltp-testsuite.mk

index 711c859e6caf53dff3700961733767a4b2344acf..500a8c2688ee038aff27c4d26a5749094220ce00 100644 (file)
@@ -15,6 +15,7 @@ config BR2_PACKAGE_LTP_TESTSUITE
        depends on !BR2_TOOLCHAIN_USES_MUSL
        depends on BR2_PACKAGE_LTP_TESTSUITE_ARCH_SUPPORTS
        select BR2_PACKAGE_LIBTIRPC if !BR2_TOOLCHAIN_HAS_NATIVE_RPC
+       select BR2_PACKAGE_MUSL_FTS if !BR2_TOOLCHAIN_USES_GLIBC
        help
          The Linux Test Project provides a huge testsuite for Linux.
 
index 2276b75f8cf57827ffe174798f88f95be1d1e86b..0c850d2b677d03168ab798f62003a98629b067aa 100644 (file)
@@ -51,13 +51,18 @@ LTP_TESTSUITE_CFLAGS += "`$(PKG_CONFIG_HOST_BINARY) --cflags libtirpc`"
 LTP_TESTSUITE_LIBS += "`$(PKG_CONFIG_HOST_BINARY) --libs libtirpc`"
 endif
 
+ifeq ($(BR2_TOOLCHAIN_USES_GLIBC),)
+LTP_TESTSUITE_DEPENDENCIES += musl-fts
+LTP_TESTSUITE_LIBS += -lfts
+endif
+
 LTP_TESTSUITE_CONF_ENV += \
        CFLAGS="$(LTP_TESTSUITE_CFLAGS)" \
        CPPFLAGS="$(LTP_TESTSUITE_CPPFLAGS)" \
        LIBS="$(LTP_TESTSUITE_LIBS)" \
        SYSROOT="$(STAGING_DIR)"
 
-# Requires uClibc fts and bessel support, normally not enabled
+# Requires uClibc bessel support, normally not enabled
 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC),y)
 define LTP_TESTSUITE_REMOVE_UNSUPPORTED
        rm -rf $(@D)/testcases/misc/math/float/bessel/