package/cegui: use plain assignemnt for first _CONF_OPTS
authorBartosz Bilas <b.bilas@grinn-global.com>
Thu, 18 Feb 2021 17:59:05 +0000 (18:59 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 19 Feb 2021 21:46:29 +0000 (22:46 +0100)
Commit 689b9c1a7cf5 (package/cegui: disable xerces support) added
an unconditional assignment to _CONF_OPTS before all the conditional
ones, but used the append-assignment instead of the traditional plain
assignment.

Fix that by removing the append-assignment.

Use that opportunity to also move the first item of this multi-line
assignment, to its own line.

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
[yann.morin.1998@free.fr:
  - reference the exact commit that introduce the issue
  - also move the first item to its own line
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/cegui/cegui.mk

index 23919e0151db55d9e482941469449bc70f2ae1ad..d578c9913c3858e995047891bbd45414e8131392 100644 (file)
@@ -9,7 +9,8 @@ CEGUI_SITE = $(call github,cegui,cegui,v$(CEGUI_VERSION))
 CEGUI_LICENSE = MIT
 CEGUI_LICENSE_FILES = COPYING
 CEGUI_INSTALL_STAGING = YES
-CEGUI_CONF_OPTS += -DCEGUI_BUILD_XMLPARSER_XERCES=OFF \
+CEGUI_CONF_OPTS = \
+       -DCEGUI_BUILD_XMLPARSER_XERCES=OFF \
        -DCEGUI_HAS_MINIZIP_RESOURCE_PROVIDER=OFF \
        -DCEGUI_BUILD_RENDERER_OGRE=OFF
 CEGUI_DEPENDENCIES = glm \