u-boot: evaluate U_BOOT_ARCH at use time, rather than Makefile parse time
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 11 Jun 2008 13:07:03 +0000 (13:07 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 11 Jun 2008 13:07:03 +0000 (13:07 -0000)
U_BOOT_ARCH seems to race with KERNEL_ARCH in some situations,
so it end up empty. It's only used once, so fix it by using a
use-time evaluated variable instead (=).

target/u-boot/Makefile.in

index 6ba5c0f10a1b528e5dbdc105b581f89d88ed33bc..541e71f7869c511c29cc709a437e123f6ad84d3f 100644 (file)
@@ -12,7 +12,7 @@ U_BOOT_CAT:=$(BZCAT)
 U_BOOT_BIN:=u-boot.bin
 U_BOOT_TOOLS_BIN:=mkimage
 # u-boot still uses arch=ppc for powerpc
-U_BOOT_ARCH:=$(shell echo $(KERNEL_ARCH)|$(HOST_SED_DIR)/bin/sed 's/powerpc/ppc/')
+U_BOOT_ARCH=$(shell echo $(KERNEL_ARCH)|$(HOST_SED_DIR)/bin/sed 's/powerpc/ppc/')
 
 ifneq ($(BR2_TARGET_U_BOOT_CONFIG_BOARD),)
 U_BOOT_INC_CONF_FILE:=$(U_BOOT_DIR)/include/configs/$(subst _config,,$(BR2_TARGET_U_BOOT_CONFIG_BOARD)).h