package/zbar: bump version to 0.22
authorPeter Seiderer <ps.report@gmx.net>
Sat, 9 Mar 2019 21:32:35 +0000 (22:32 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 12 Mar 2019 22:09:32 +0000 (23:09 +0100)
- change from git download to official release and
  download site (drop need for autoreconf)

- drop dependency on kernel headers >= 3.17 (should be fixed with
  commit 'v4l2: make ZBar build and run on Kernels < 3.16' (see [1]),
  fall back to original kernel headers >= 3.0 dependency propagated
  from libv4l

[1] https://git.linuxtv.org/zbar.git/commit/?id=fa5c48127ec1e3670e28540c2e6a03431ebac5b8

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gstreamer/gst-plugins-bad/Config.in
package/zbar/Config.in
package/zbar/zbar.hash
package/zbar/zbar.mk

index 411e4b61744fc2c077a6eec2361c59ba4c224e89..982edc2e4c82a609bc8f968ae4673ea921f68bcb 100644 (file)
@@ -321,12 +321,12 @@ config BR2_PACKAGE_GST_PLUGINS_BAD_ZBAR
        depends on BR2_TOOLCHAIN_HAS_THREADS # zbar-> libv4l
        depends on BR2_USE_MMU # zbar-> libv4l
        depends on BR2_INSTALL_LIBSTDCPP # zbar-> libv4l
-       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_17 # zbar
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 # zbar -> libv4l
        select BR2_PACKAGE_ZBAR
 
-comment "zbar plugin needs a toolchain w/ threads, C++ and headers >= 3.17"
+comment "zbar plugin needs a toolchain w/ threads, C++ and headers >= 3.0"
        depends on BR2_USE_MMU
        depends on !BR2_TOOLCHAIN_HAS_THREADS \
-               || !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_17
+               || !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0
 
 endif
index e850c1f02bdd28bb826ab8c35fde317aa86b8748..0f4d115745ad24865a5b59e3568cdb96b50f4c21 100644 (file)
@@ -3,7 +3,7 @@ config BR2_PACKAGE_ZBAR
        depends on BR2_TOOLCHAIN_HAS_THREADS # libv4l
        depends on BR2_USE_MMU # libv4l
        depends on BR2_INSTALL_LIBSTDCPP # libv4l
-       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_17 # v4l2_query_ext_ctrl
+       depends on BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0 # libv4l
        select BR2_PACKAGE_JPEG
        select BR2_PACKAGE_LIBV4L
        help
@@ -11,7 +11,7 @@ config BR2_PACKAGE_ZBAR
 
          https://git.linuxtv.org/zbar.git/about/
 
-comment "zbar needs a toolchain w/ threads, C++ and headers >= 3.17"
+comment "zbar needs a toolchain w/ threads, C++ and headers >= 3.0"
        depends on BR2_USE_MMU
        depends on !BR2_TOOLCHAIN_HAS_THREADS \
-               || !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_17
+               || !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0
index 47a080af12ae5da283541828c6d14ca51138f280..0f44d0f5c0d81732e5b3dbf788dc43c9d50e8063 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed:
-sha256 7eb73c180c787184ede0f98806c52b23eb9c24609673e1ed51210504ea2937f5 zbar-681b0f305fb5c5bb0df8437f7d740b29a93a7889.tar.gz
+sha256 1ba9e94c7217a8bd3800f9f3abddf3ed393a62cdf141a709765aad2788744eb7 zbar-0.22.tar.bz2
 sha256 36b6d3fa47916943fd5fec313c584784946047ec1337a78b440e5992cb595f89 LICENSE
index 2146aee85b0eeb2e05b500c796266056ea6b421d..63220774b94203210fc7239d3cbfb29102b7bf67 100644 (file)
@@ -4,12 +4,12 @@
 #
 ################################################################################
 
-ZBAR_VERSION = 681b0f305fb5c5bb0df8437f7d740b29a93a7889
-ZBAR_SITE = git://linuxtv.org/zbar.git
+ZBAR_VERSION = 0.22
+ZBAR_SOURCE = zbar-$(ZBAR_VERSION).tar.bz2
+ZBAR_SITE = https://www.linuxtv.org/downloads/zbar
 ZBAR_LICENSE = LGPL-2.1+
 ZBAR_LICENSE_FILES = LICENSE
 ZBAR_INSTALL_STAGING = YES
-ZBAR_AUTORECONF = YES
 ZBAR_DEPENDENCIES = libv4l jpeg
 # add host-gettext for AM_ICONV macro
 ZBAR_DEPENDENCIES += host-gettext