autofs: allow to use libtirpc
authorWaldemar Brodkorb <wbx@openadk.org>
Thu, 1 Feb 2018 20:09:04 +0000 (21:09 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 6 Feb 2018 13:05:44 +0000 (14:05 +0100)
uClibc-ng removed internal RPC implementation as it
is ipv4 only and can not be used for most important RPC software
rpcbind and nfs-utils.
musl does not implement RPC and GNU C library deprecated the
internal implementation a while ago.
It is still possible to use the C library implementation.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
[Thomas: change to use libtirpc when available, not just when the
toolchain does not have RPC support.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/autofs/Config.in
package/autofs/autofs.mk

index 8e08357a4e4a985a6519e4614497fd41ceb76ab7..efb0ec28ee7de129da46155f61c5e1882cf91a56 100644 (file)
@@ -2,8 +2,8 @@ config BR2_PACKAGE_AUTOFS
        bool "autofs"
        depends on BR2_TOOLCHAIN_HAS_THREADS_NPTL
        depends on BR2_USE_MMU
-       depends on BR2_TOOLCHAIN_HAS_NATIVE_RPC
        depends on !BR2_STATIC_LIBS # dlfcn
+       select BR2_PACKAGE_LIBTIRPC if !BR2_TOOLCHAIN_HAS_NATIVE_RPC
        help
          Autofs controls the operation of the automount daemons. The
          automount daemons automatically mount filesystems when they
@@ -15,7 +15,6 @@ config BR2_PACKAGE_AUTOFS
 
          http://www.linuxfromscratch.org/blfs/view/svn/general/autofs.html
 
-comment "autofs needs a toolchain w/ NPTL, RPC, dynamic library"
+comment "autofs needs a toolchain w/ NPTL and dynamic library"
        depends on BR2_USE_MMU
-       depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_STATIC_LIBS || \
-               !BR2_TOOLCHAIN_HAS_NATIVE_RPC
+       depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL || BR2_STATIC_LIBS
index 90cc38de558b58683d5bfc25a87468368c1d4da9..87a218441e3490fc76cb2adafebd7fe702ba018a 100644 (file)
@@ -9,7 +9,7 @@ AUTOFS_SOURCE = autofs-$(AUTOFS_VERSION).tar.xz
 AUTOFS_SITE = $(BR2_KERNEL_MIRROR)/linux/daemons/autofs/v5
 AUTOFS_LICENSE = GPL-2.0+
 AUTOFS_LICENSE_FILES = COPYING COPYRIGHT
-AUTOFS_DEPENDENCIES = host-flex host-bison
+AUTOFS_DEPENDENCIES = host-flex host-bison host-pkgconf
 
 # autofs looks on the build machine for the path of modprobe, so tell
 # it explicitly where it will be located on the target.
@@ -31,4 +31,11 @@ AUTOFS_CONF_OPTS = \
 
 AUTOFS_MAKE_ENV = DONTSTRIP=1
 
+ifeq ($(BR2_PACKAGE_LIBTIRPC),y)
+AUTOFS_CONF_OPTS += --with-libtirpc
+AUTOFS_DEPENDENCIES += libtirpc
+else
+AUTOFS_CONF_OPTS += --without-libtirpc
+endif
+
 $(eval $(autotools-package))