ncurses: Add libcurses symlink to libncurses
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Tue, 23 Sep 2014 09:33:11 +0000 (10:33 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 25 Sep 2014 09:01:01 +0000 (11:01 +0200)
Some packages use -lcurses when they are linking, so they try to link to
a library called libcurses. The library provided by our ncurses package
is called libncurses, so those packages fail to link with a message like
this one:

/bin/ld: cannot find -lcurses

Installing a libcurses symlink to libncurses fixes the problem.

Fixes:
  http://autobuild.buildroot.net/results/466/466995f9534447a4f54327a14c44ef9e16dd1123/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Reviewed-by: Markos Chandras <Markos.Chandras@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ncurses/ncurses.mk

index 81a39988adfd050f571e01c6c7527bae964dd598..3f574076dea3b5ff391588ac554aac9fb84ce5d1 100644 (file)
@@ -46,6 +46,8 @@ define NCURSES_LINK_LIBS
                ln -sf $${lib}$(NCURSES_LIB_SUFFIX).a \
                        $(1)/usr/lib/$${lib}.a; \
        done
+       ln -sf libncurses$(NCURSES_LIB_SUFFIX).a \
+               $(1)/usr/lib/libcurses.a
 endef
 else
 define NCURSES_LINK_LIBS
@@ -55,6 +57,10 @@ define NCURSES_LINK_LIBS
                ln -sf $${lib}$(NCURSES_LIB_SUFFIX).so \
                        $(1)/usr/lib/$${lib}.so; \
        done
+       ln -sf libncurses$(NCURSES_LIB_SUFFIX).a \
+               $(1)/usr/lib/libcurses.a
+       ln -sf libncurses$(NCURSES_LIB_SUFFIX).so \
+               $(1)/usr/lib/libcurses.so
 endef
 endif