libxml2: fixup configure options
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 2 May 2011 19:08:22 +0000 (16:08 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 2 May 2011 19:40:04 +0000 (21:40 +0200)
Some configure options changed so adjust.
Forcibly disabling threads isn't good and also it's detected by
configure when there are no threads.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libxml2/libxml2.mk

index 2a267b2f9e683c93cfc95b9db9f4c50987e5ca42..8f2878d6564d8202b0f88c8587b2791150215653 100644 (file)
@@ -12,10 +12,7 @@ ifneq ($(BR2_LARGEFILE),y)
 LIBXML2_CONF_ENV = CC="$(TARGET_CC) $(TARGET_CFLAGS) -DNO_LARGEFILE_SOURCE"
 endif
 
-LIBXML2_CONF_OPT = --with-gnu-ld --enable-shared \
-               --enable-static \
-               --without-debugging --without-python \
-               --without-threads
+LIBXML2_CONF_OPT = --with-gnu-ld --without-python --without-debug
 
 define LIBXML2_STAGING_LIBXML2_CONFIG_FIXUP
        $(SED) "s,^prefix=.*,prefix=\'$(STAGING_DIR)/usr\',g" $(STAGING_DIR)/usr/bin/xml2-config
@@ -26,9 +23,7 @@ LIBXML2_POST_INSTALL_STAGING_HOOKS += LIBXML2_STAGING_LIBXML2_CONFIG_FIXUP
 
 HOST_LIBXML2_DEPENDENCIES = host-pkg-config
 
-HOST_LIBXML2_CONF_OPT = \
-               --enable-shared --without-debugging --without-python \
-               --without-threads
+HOST_LIBXML2_CONF_OPT = --without-debug --without-python
 
 define LIBXML2_REMOVE_CONFIG_SCRIPTS
        $(RM) -f $(TARGET_DIR)/usr/bin/xml2-config