gnutls: fix libopts detection causing build failures
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Dec 2013 16:14:44 +0000 (17:14 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 25 Dec 2013 16:14:44 +0000 (17:14 +0100)
Following the recent bump of gnutls to version 3.2.8, the build
started to fail on some machines where libopts is installed on the
system: gnutls configure script was incorrectly assuming that libopts
was available.

Since we don't have a package in Buildroot, this commit tells gnutls
to use its builtin libopts version.

Fixes (tested on gcc20):

  http://autobuild.buildroot.org/results/18f/18f61b3be6aed73f83b449b5082492a4a6ba8ffb/build-end.log

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gnutls/gnutls.mk

index 7cbfcb1b76ab0bd7bb5c1a981530daf45ba906fa..9ad673e0cac6f3bad224408c71ed88af6bee01e7 100644 (file)
@@ -15,8 +15,12 @@ GNUTLS_DEPENDENCIES = host-pkgconf nettle pcre \
        $(if $(BR2_PACKAGE_LIBIDN),libidn) \
        $(if $(BR2_PACKAGE_LIBTASN1),libtasn1) \
        $(if $(BR2_PACKAGE_ZLIB),zlib)
-GNUTLS_CONF_OPT = --with-libnettle-prefix=$(STAGING_DIR)/usr --disable-rpath \
-       --disable-doc --disable-guile
+GNUTLS_CONF_OPT = \
+       --with-libnettle-prefix=$(STAGING_DIR)/usr \
+       --disable-rpath \
+       --disable-doc \
+       --disable-guile \
+       --enable-local-libopts
 GNUTLS_CONF_ENV = gl_cv_socket_ipv6=$(if $(BR2_INET_IPV6),yes,no) \
        ac_cv_header_wchar_h=$(if $(BR2_USE_WCHAR),yes,no) \
        gt_cv_c_wchar_t=$(if $(BR2_USE_WCHAR),yes,no) \