Revert "czmq: unbreak static linking"
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 13 May 2015 07:16:27 +0000 (09:16 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 13 May 2015 07:16:27 +0000 (09:16 +0200)
This reverts commit aa5254f1a2bc0ea3181d51990c18681b3071b9db.

Now that zeromq's pkg-config file is fixed, we no longer need this
workaround for static linking.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/czmq/czmq.mk

index 789e70027f69bd590956e4e7f4e132c7c9df11f6..d25bf01c63a475e7768d206cd9562e9e95c2ed68 100644 (file)
@@ -18,12 +18,6 @@ CZMQ_LICENSE_FILES = LICENSE
 # host-python, so disable asciidoc entirely.
 CZMQ_CONF_ENV = ac_cv_prog_czmq_have_asciidoc=no
 
-# zeromq uses C++, but czmq forgets to explicitly link with libstdc++
-# (or use g++ to link), breaking static linking.
-ifeq ($(BR2_STATIC_LIBS),y)
-CZMQ_CONF_ENV += LIBS='-lstdc++'
-endif
-
 define CZMQ_CREATE_CONFIG_DIR
        mkdir -p $(@D)/config
 endef