samba4: fix readline support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 3 Mar 2014 11:44:12 +0000 (08:44 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Mar 2014 20:25:51 +0000 (21:25 +0100)
Add automatic readline support since it's used when available.
Also add a patch to update to new-style typedefs that were removed from
readline 6.3 that causes build breakage. Fixes:
http://autobuild.buildroot.net/results/b13/b137c237ff6df81dd10f7895278d1f2f5d2326de/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/samba4/samba4-0006-smbreadline-switch-to-new-style-readline-typedef.patch [new file with mode: 0644]
package/samba4/samba4.mk

diff --git a/package/samba4/samba4-0006-smbreadline-switch-to-new-style-readline-typedef.patch b/package/samba4/samba4-0006-smbreadline-switch-to-new-style-readline-typedef.patch
new file mode 100644 (file)
index 0000000..65d0950
--- /dev/null
@@ -0,0 +1,32 @@
+From 0d4f18b88c3e687b83dcbe4c27f74424cf2f2043 Mon Sep 17 00:00:00 2001
+From: Gustavo Zacarias <gustavo@zacarias.com.ar>
+Date: Mon, 3 Mar 2014 07:57:24 -0300
+Subject: [PATCH] smbreadline: switch to new-style readline typedef
+
+Function, CPFunction, CPPFunction and VFunction typedefs are considered
+old-style (deprecated) starting from readline 4.2.
+Compatibility typedefs have been in place up to readline 6.2 but were
+removed with the 6.3 release thus causing builds to break.
+Swtich to the new-style specific prototyped typedef.
+
+Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
+---
+ libcli/smbreadline/smbreadline.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libcli/smbreadline/smbreadline.c b/libcli/smbreadline/smbreadline.c
+index cff25a7..80e10b0 100644
+--- a/libcli/smbreadline/smbreadline.c
++++ b/libcli/smbreadline/smbreadline.c
+@@ -141,7 +141,7 @@ char *smb_readline(const char *prompt, void (*callback)(void),
+ #if HAVE_DECL_RL_EVENT_HOOK
+       if (callback)
+-              rl_event_hook = (Function *)callback;
++              rl_event_hook = (rl_hook_func_t *)callback;
+ #endif
+       ret = readline(prompt);
+       if (ret && *ret)
+-- 
+1.8.3.2
+
index 452c6941a74055dce4c5cac9d8928646cfc7be84..72710bf241279ceaa46dac7d47a40d057e7bbb76 100644 (file)
@@ -10,7 +10,8 @@ SAMBA4_SOURCE = samba-$(SAMBA4_VERSION).tar.gz
 SAMBA4_LICENSE = GPLv3+
 SAMBA4_LICENSE_FILES = COPYING
 SAMBA4_DEPENDENCIES = host-e2fsprogs host-heimdal e2fsprogs popt python zlib \
-       $(if $(BR2_PACKAGE_LIBCAP),libcap)
+       $(if $(BR2_PACKAGE_LIBCAP),libcap) \
+       $(if $(BR2_PACKAGE_READLINE),readline)
 
 ifeq ($(BR2_PACKAGE_ACL),y)
        SAMBA4_CONF_OPT += --with-acl-support