httping: fix math library linking
authorYuvaraj Patil <yuvaraj.patil@wipro.com>
Wed, 23 Jul 2014 11:47:22 +0000 (17:17 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 29 Jul 2014 18:43:09 +0000 (20:43 +0200)
Add the math library directive '-lm' to linker options at the end.
The order of the math library directive '-lm' matters.

Fixes:

  http://autobuild.buildroot.net/results/843/84382290696e72c23995f5ed020ad5c157817012/

Signed-off-by: Yuvaraj Patil <yuvaraj.patil@wipro.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/httping/httping-0001-fix-math-library-linking.patch [new file with mode: 0644]

diff --git a/package/httping/httping-0001-fix-math-library-linking.patch b/package/httping/httping-0001-fix-math-library-linking.patch
new file mode 100644 (file)
index 0000000..0078f41
--- /dev/null
@@ -0,0 +1,25 @@
+Move LDFLAGS+=-lm option to the end.
+The order of the math library directive '-lm' matters.
+
+Signed-off-by: Yuvaraj Patil <yuvaraj.patil@wipro.com>
+---
+diff -Nurp httping-2.3.4_orig/Makefile httping-2.3.4/Makefile
+--- httping-2.3.4_orig/Makefile        2014-07-23 16:16:36.495546288 +0530
++++ httping-2.3.4/Makefile     2014-07-23 16:18:42.547541002 +0530
+@@ -37,7 +37,6 @@ DEBUG=yes
+ WFLAGS=-Wall -W
+ OFLAGS=
+ CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\" -DLOCALEDIR=\"$(LOCALEDIR)\"
+-LDFLAGS+=-lm
+ PACKAGE=$(TARGET)-$(VERSION)
+ PREFIX?=/usr
+@@ -97,6 +96,8 @@ ifeq ($(ARM),yes)
+ CC=arm-linux-gcc
+ endif
++LDFLAGS+=-lm
++
+ all: $(TARGET) $(TRANSLATIONS)
+ $(TARGET): $(OBJS)