opkg: bump to version 0.3.6
authorBaruch Siach <baruch@tkos.co.il>
Tue, 22 May 2018 18:56:51 +0000 (21:56 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 22 May 2018 21:32:47 +0000 (23:32 +0200)
Use upstream provided tarball and hash.

The tarball conf/ subdirectory contains symlinks to host automake and
libtool scripts. We can't rely on these being present or usable. Remove
the symlinks, and keep autoreconf to populate the conf/ subdirectory
using Buildroot provided autotools.

Cc: Derek Baker <Derek-Baker@idexx.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/opkg/opkg.hash
package/opkg/opkg.mk

index 80f3f0d1d2ca4e85810bbf090830d5a566cef293..321c41dbd051e465675441b06e66fc60f3d79c1c 100644 (file)
@@ -1,2 +1,2 @@
-# Locally computed
-sha256 2ec7157ccf866e49ca139e3632ba1ca9d61dc24382606b55062e423161a530b0  opkg-v0.3.1.tar.gz
+# From http://downloads.yoctoproject.org/releases/opkg/SHA256SUMS
+sha256 f607f0e61be8cf8a3bbd0d2dccd9ec9e9b6c21dd4307b671c600d6eeaf84d30b  opkg-0.3.6.tar.gz
index 0c7e15ea7523e6f3bdf38fea5642b12308370e28..4d34c6d4d3a21221e2891a2ceed6ca495bb346c1 100644 (file)
@@ -4,15 +4,14 @@
 #
 ################################################################################
 
-OPKG_VERSION = v0.3.1
-OPKG_SITE = http://git.yoctoproject.org/git/opkg
-OPKG_SITE_METHOD = git
-# Uses PKG_CHECK_MODULES() in configure.ac
+OPKG_VERSION = 0.3.6
+OPKG_SITE = http://downloads.yoctoproject.org/releases/opkg
 OPKG_DEPENDENCIES = host-pkgconf libarchive
 OPKG_LICENSE = GPL-2.0+
 OPKG_LICENSE_FILES = COPYING
 OPKG_INSTALL_STAGING = YES
 OPKG_CONF_OPTS = --disable-curl
+# Populate the conf/ directory
 OPKG_AUTORECONF = YES
 
 # Ensure directory for lockfile exists
@@ -20,6 +19,14 @@ define OPKG_CREATE_LOCKDIR
        mkdir -p $(TARGET_DIR)/usr/lib/opkg
 endef
 
+# The conf/ directory contains symlinks to host automake and libtool provided
+# scripts. Don't rely on them being present.
+define OPKG_REMOVE_AUTOTOOLS_SYMLINKS
+       rm $(@D)/conf/*
+endef
+
+OPKG_POST_EXTRACT_HOOKS += OPKG_REMOVE_AUTOTOOLS_SYMLINKS
+
 ifeq ($(BR2_PACKAGE_OPKG_GPG_SIGN),y)
 OPKG_CONF_OPTS += --enable-gpg
 OPKG_CONF_ENV += \