package/mplayer: add optional speex support
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 29 Mar 2015 17:11:29 +0000 (19:11 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 8 Apr 2015 21:00:44 +0000 (23:00 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/mplayer/mplayer.mk

index 412837dc7ac4a06f7c6fa2d5c2b6f699bf7e6884..5e295515f40c12aa9fd2f8b6ef7f4b95676a42bc 100644 (file)
@@ -174,6 +174,13 @@ else
 MPLAYER_CONF_OPTS += --disable-librtmp
 endif
 
+ifeq ($(BR2_PACKAGE_SPEEX),y)
+MPLAYER_DEPENDENCIES += speex
+MPLAYER_CONF_OPTS += --enable-speex
+else
+MPLAYER_CONF_OPTS += --disable-speex
+endif
+
 ifeq ($(BR2_PACKAGE_LZO),y)
 MPLAYER_DEPENDENCIES += lzo
 MPLAYER_CONF_OPTS += --enable-liblzo