Remove all documentation when BR2_HAVE_DOCUMENTATION is not set
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 10 Apr 2010 20:42:45 +0000 (22:42 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 11 Apr 2010 04:01:08 +0000 (06:01 +0200)
Until now, we had BR2_HAVE_MANPAGES, BR2_HAVE_INFOPAGES and
BR2_HAVE_DOCUMENTATION, but there's no need to have such a
fine-grained control over what documentation gets kept or not.

Therefore, just remove all the documentation (man pages, info pages
and documentation in $(TARGET_DIR)/usr/doc and
$(TARGET_DIR)/usr/share/doc) when BR2_HAVE_DOCUMENTATION is not set.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index ce6bf3d4cf9ff414c89f1f4b4b21cdf0189b7ca0..03ed4c5051e234c6207533e91925e5fb743535d9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -409,11 +409,10 @@ else
        find $(TARGET_DIR)/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
        find $(TARGET_DIR)/usr/lib \( -name '*.a' -o -name '*.la' \) -print0 | xargs -0 rm -f
 endif
-ifneq ($(BR2_HAVE_MANPAGES),y)
+ifneq ($(BR2_HAVE_DOCUMENTATION),y)
        rm -rf $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/man
-endif
-ifneq ($(BR2_HAVE_INFOPAGES),y)
        rm -rf $(TARGET_DIR)/usr/info $(TARGET_DIR)/usr/share/info
+       rm -rf $(TARGET_DIR)/usr/doc $(TARGET_DIR)/usr/share/doc
 endif
        find $(TARGET_DIR) -type f -perm +111 | xargs $(STRIPCMD) 2>/dev/null || true
        $(TARGET_LDCONFIG) -r $(TARGET_DIR) 2>/dev/null