package/multimedia/gst-plugins-good/gst-plugins-good.mk
authorDaniel Laird <danieljlaird@hotmail.com>
Wed, 21 Jan 2009 13:33:21 +0000 (13:33 -0000)
committerDaniel Laird <danieljlaird@hotmail.com>
Wed, 21 Jan 2009 13:33:21 +0000 (13:33 -0000)
package/multimedia/gst-plugins-good/Config.in

gst-plugins-good does not build unless some package dependencies are forced.
This patch allows you to turn off some of the plugins with these dependencies and hides
others that require some packages (like PNG/JPEG)

Signed-off-by: Daniel Laird <daniel.j.laird@nxp.com>
package/multimedia/gst-plugins-good/Config.in
package/multimedia/gst-plugins-good/gst-plugins-good.mk

index 22241d54fd76cc18bdc25e69203436f1fb6d5a6d..e36ccdad57dd8c7996d034148123ee9fe9669270 100644 (file)
@@ -72,6 +72,7 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_LEVEL
 
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MATROSKA
        bool "matroska"
+       depends on BR2_PACKAGE_BZIP2 && BR2_PACKAGE_ZLIB
 
 config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MONOSCOPE
        bool "monoscope"
@@ -119,4 +120,25 @@ config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_WAVPARSE
        bool "wavparse (*.wav audio)"
        default y
 
+comment "plugins with external dependencies (more to come)"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ANNODEX
+       bool "annodex (XML Library)"
+       default y
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ESD
+       bool "esdsink (ESounD sound daemon)"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_JPEG
+       bool "jpeg (JPEG support)"
+       depends on BR2_PACKAGE_JPEG
+       default y
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS
+       bool "ossaudio (OSS audio)"
+
+config BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_PNG
+       bool "png (PNG support)"
+       depends on BR2_PACKAGE_LIBPNG
+       default y
 endif
index bef8d01b0d6c80a0d81a95deb33f549c65b3ec50..c120edbb333f0153df32743f1c030479e59a110a 100644 (file)
@@ -142,6 +142,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_MATROSKA),y)
 GST_PLUGINS_GOOD_CONF_OPT += --enable-matroska
+GST_PLUGINS_GOOD_DEPENDENCIES += zlib bzip2
 else
 GST_PLUGINS_GOOD_CONF_OPT += --disable-matroska
 endif
@@ -236,4 +237,36 @@ else
 GST_PLUGINS_GOOD_CONF_OPT += --disable-wavparse
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ANNODEX),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-annodex
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-annodex
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_ESD),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-esd
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-esd
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_JPEG),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-jpeg
+GST_PLUGINS_GOOD_DEPENDENCIES += jpeg
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-jpeg
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_OSS),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-oss
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-oss
+endif
+
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_GOOD_PLUGIN_PNG),y)
+GST_PLUGINS_GOOD_CONF_OPT += --enable-png
+GST_PLUGINS_GOOD_DEPENDENCIES += libpng
+else
+GST_PLUGINS_GOOD_CONF_OPT += --disable-png
+endif
+
 $(eval $(call AUTOTARGETS,package/multimedia,gst-plugins-good))