package/ncmpc: add pcre optional dependency
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 8 Feb 2019 21:40:48 +0000 (22:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 10 Feb 2019 14:08:43 +0000 (15:08 +0100)
pcre dependency has been added in version 0.32:
https://github.com/MusicPlayerDaemon/ncmpc/commit/0b3169510014f0f336de58864b97a3cc0f308500

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/ncmpc/ncmpc.mk

index 4167974490a5a3c2b4ae2de02eaf34113ca87c39..2e52be27d5af0c7f0a1812f222f5e30d4d5cce64 100644 (file)
@@ -14,8 +14,7 @@ NCMPC_LICENSE_FILES = COPYING
 
 NCMPC_CONF_OPTS = \
        -Dcurses=ncurses \
-       -Ddocumentation=disabled \
-       -Dregex=disabled
+       -Ddocumentation=disabled
 
 ifeq ($(BR2_PACKAGE_LIRC_TOOLS),y)
 NCMPC_DEPENDENCIES += lirc-tools
@@ -24,4 +23,11 @@ else
 NCMPC_CONF_OPTS += -Dlirc=disabled
 endif
 
+ifeq ($(BR2_PACKAGE_PCRE),y)
+NCMPC_DEPENDENCIES += pcre
+NCMPC_CONF_OPTS += -Dregex=enabled
+else
+NCMPC_CONF_OPTS += -Dregex=disabled
+endif
+
 $(eval $(meson-package))