package/htpdate: fix build with static openssl
authorTitouan Christophe <titouan.christophe@railnova.eu>
Sat, 12 Sep 2020 15:05:27 +0000 (17:05 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 13 Sep 2020 19:39:31 +0000 (21:39 +0200)
Depending on its build configuration, openssl might not be compiled with
dynamic zlib support, and programs that link against openssl need to link
against zlib as well.

This can be generally and easily handled using the pkg-config files
installed by openssl.

Fixes: http://autobuild.buildroot.net/results/ae9/ae946ca72238840b3eaa5fe823e8d620618f7462/
Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/htpdate/0001-Use-pkg-config-to-determine-openssl-LDFLAGS.patch [new file with mode: 0644]
package/htpdate/htpdate.mk

diff --git a/package/htpdate/0001-Use-pkg-config-to-determine-openssl-LDFLAGS.patch b/package/htpdate/0001-Use-pkg-config-to-determine-openssl-LDFLAGS.patch
new file mode 100644 (file)
index 0000000..2dad41a
--- /dev/null
@@ -0,0 +1,36 @@
+From 32d6cec3be361c3d2228967d41b868b7b3b910c0 Mon Sep 17 00:00:00 2001
+From: Titouan Christophe <titouan.christophe@railnova.eu>
+Date: Sat, 12 Sep 2020 16:49:57 +0200
+Subject: [PATCH] Use pkg-config to determine openssl LDFLAGS
+
+Depending on its build configuration, openssl might not be compiled with
+dynamic zlib support, and programs that link against openssl need to link
+against zlib as well, as illustrated in this build failure:
+http://autobuild.buildroot.net/results/ae9/ae946ca72238840b3eaa5fe823e8d620618f7462/
+
+Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
+[upstream status: https://github.com/angeloc/htpdate/pull/1]
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 09eea4a..21668a6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -4,10 +4,11 @@ mandir = ${prefix}/share/man
+ CC ?= gcc
+ CFLAGS += -Wall -std=c99 -pedantic -O2
++PKG_CONFIG ?= pkg-config
+ ifdef ENABLE_HTTPS
+ CFLAGS += -DENABLE_HTTPS
+-LDFLAGS += -lssl -lcrypto
++LDFLAGS += $(shell $(PKG_CONFIG) --libs openssl)
+ endif
+ INSTALL = install -c
+-- 
+2.25.3
+
index 99d3adafcdd60c90bc45c6923a3d1cf641e680f2..ed748304942129e90c3012baa5fbd0ef13d0bdb1 100644 (file)
@@ -11,7 +11,7 @@ HTPDATE_LICENSE_FILES = LICENSE
 
 ifeq ($(BR2_PACKAGE_OPENSSL),y)
 HTPDATE_BUILD_OPTS = ENABLE_HTTPS=1
-HTPDATE_DEPENDENCIES += openssl
+HTPDATE_DEPENDENCIES += openssl host-pkgconf
 endif
 
 define HTPDATE_BUILD_CMDS