libdri2: new package
authorJérôme Oufella <jerome.oufella@savoirfairelinux.com>
Wed, 11 Mar 2015 20:30:22 +0000 (16:30 -0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 15 Mar 2015 13:57:47 +0000 (14:57 +0100)
libdri2 is a library for the DRI2 extension to the X Window System. This
is the split out dri2 client side code from mesa, libva, libvdpau, etc..

It can be used by applications or user-space drivers to provide
accelerated graphics.

Signed-off-by: Jérôme Oufella <jerome.oufella@savoirfairelinux.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/libdri2/Config.in [new file with mode: 0644]
package/libdri2/libdri2.mk [new file with mode: 0644]

index 3326c9d1378a58a5e9c23bb20b4c62fd7812e1a6..95618dbf2aa5b47840cbc15fa09e9c4c7c867ffc 100644 (file)
@@ -711,6 +711,7 @@ menu "Graphics"
        source "package/lesstif/Config.in"
        source "package/libart/Config.in"
        source "package/libdmtx/Config.in"
+       source "package/libdri2/Config.in"
        source "package/libdrm/Config.in"
        source "package/libexif/Config.in"
        source "package/libgail/Config.in"
diff --git a/package/libdri2/Config.in b/package/libdri2/Config.in
new file mode 100644 (file)
index 0000000..badd52e
--- /dev/null
@@ -0,0 +1,16 @@
+config BR2_PACKAGE_LIBDRI2
+       bool "libdri2"
+       select BR2_PACKAGE_LIBDRM
+       select BR2_PACKAGE_XLIB_LIBXDAMAGE
+       select BR2_PACKAGE_XLIB_LIBXEXT
+       select BR2_PACKAGE_XPROTO_DRI2PROTO
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libdrm
+       depends on BR2_LARGEFILE # libdrm
+       depends on BR2_PACKAGE_XORG7
+       help
+         Library for the DRI2 extension to the X Window System.
+
+         https://github.com/robclark/libdri2
+
+comment "libdri2 needs a toolchain w/ largefile, threads"
+       depends on !BR2_LARGEFILE || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libdri2/libdri2.mk b/package/libdri2/libdri2.mk
new file mode 100644 (file)
index 0000000..22854b5
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# libdri2
+#
+################################################################################
+
+LIBDRI2_VERSION = 4f1eef3183df2b270c3d5cbef07343ee5127a6a4
+LIBDRI2_SITE = $(call github,robclark,libdri2,$(LIBDRI2_VERSION))
+LIBDRI2_DEPENDENCIES = xlib_libXext xproto_dri2proto xlib_libXdamage libdrm
+LIBDRI2_LICENSE = MIT
+LIBDRI2_LICENSE_FILES = COPYING
+
+LIBDRI2_INSTALL_STAGING = YES
+LIBDRI2_AUTORECONF = YES
+LIBDRI2_CONF_ENV = xorg_cv_malloc0_returns_null=true
+
+$(eval $(autotools-package))