Override the uninstall target rather than the clean target
authorHamish Moffatt <hamish@cloud.net.au>
Thu, 4 Sep 2008 02:39:23 +0000 (02:39 -0000)
committerHamish Moffatt <hamish@cloud.net.au>
Thu, 4 Sep 2008 02:39:23 +0000 (02:39 -0000)
Also, don't actually create the .stamp_uninstalled but remove the
.stamp_installed file instead (ala the overridden target).

package/bridge-utils/bridge.mk

index d8182b950f7b45c1acc38593de77f469baeee854..70fdc398137fb35db6f3fcf335f6d2fbd5dcd046 100644 (file)
@@ -22,8 +22,9 @@ $(BRIDGE_HOOK_POST_INSTALL): $(BRIDGE_TARGET_INSTALL_TARGET)
        touch $@
 
 # bridge has no uninstall target
-$(BUILD_DIR)/bridge-$(BRIDGE_VERSION)/.stamp_cleaned:
-       $(call MESSAGE,"Cleaning up")
+$(BUILD_DIR)/bridge-$(BRIDGE_VERSION)/.stamp_uninstalled:
+       $(call MESSAGE,"Uninstalling")
        rm -f $(addprefix $(TARGET_DIR)/usr/,lib/libbridge.a \
                include/libbridge.h man/man8/brctl.8 sbin/brctl)
-       touch $@
+       rm -f $(@D)/.stamp_target_installed
+