package/supertuxkart: remove libglu dependency
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 3 May 2020 17:12:27 +0000 (19:12 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 3 May 2020 17:53:11 +0000 (19:53 +0200)
"The inclusion of GLU is historical. [...] It's not needed for GLEW to
 build or run, but it's opt-out that reason. I'd recommend using
 -DGLEW_NO_GLU since GLU is rarely seen in modern codebases nowadays."
https://github.com/nigels-com/glew/issues/192#issuecomment-411641657

Supertuxkart already uses -DGLEW_NO_GLU:
https://github.com/supertuxkart/stk-code/blob/master/CMakeLists.txt#L224

This patch only removes the dependency to libglu and depends on the
previous patch of this series which removes glu from glew.pc.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/supertuxkart/Config.in
package/supertuxkart/supertuxkart.mk

index fcb27445da2537484a2a6f1b404cfa4424b144f2..e00d98d2a40bd3433f91dc797a04a8b46b2ee639 100644 (file)
@@ -16,7 +16,6 @@ config BR2_PACKAGE_SUPERTUXKART
        select BR2_PACKAGE_LIBCURL
        select BR2_PACKAGE_LIBFRIBIDI
        select BR2_PACKAGE_LIBGLEW
-       select BR2_PACKAGE_LIBGLU
        select BR2_PACKAGE_LIBOGG
        select BR2_PACKAGE_LIBPNG
        select BR2_PACKAGE_LIBSQUISH
index 4427ddd1ee07c7bc6ef031170c7107e4ca91a2db..97cd2a40b8f7bd8684ccbd15885f868fe5bef908 100644 (file)
@@ -24,7 +24,6 @@ SUPERTUXKART_DEPENDENCIES = \
        libfribidi \
        libgl \
        libglew \
-       libglu \
        libogg \
        libpng \
        libsquish \