weston: handle libxml2 dependency
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 29 Mar 2016 14:39:10 +0000 (11:39 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Mar 2016 15:01:14 +0000 (17:01 +0200)
It's used for JUnit XML output support.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/weston/weston.mk

index 9313fcccbc1ce44dd266dfe03bea96b6a83e385a..2891fe3246ba68cf47425d80dade96a2e4552f5e 100644 (file)
@@ -116,4 +116,11 @@ else
 WESTON_CONF_OPTS += --disable-systemd-login --disable-systemd-notify
 endif
 
+ifeq ($(BR2_PACKAGE_LIBXML2),y)
+WESTON_CONF_OPTS += --enable-junit-xml
+WESTON_DEPENDENCIES += libxml2
+else
+WESTON_CONF_OPTS += --disable-junit-xml
+endif
+
 $(eval $(autotools-package))