dnsmasq: bump to 2.51 and add IDN option
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Fri, 13 Nov 2009 15:12:09 +0000 (12:12 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 15 Nov 2009 22:46:53 +0000 (23:46 +0100)
Closes #717

Dnsmasq 2.51 introduces IDN support, add it to the package.
Newsworthy items:

* Add support for internationalised DNS (IDN).
* Improved upstream nameserver checks for slow nameservers.
* Improved TFTP support (win/dos filenames, new tftpserver-address option
  for DHCP).

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/dnsmasq/Config.in
package/dnsmasq/dnsmasq.mk

diff --git a/CHANGES b/CHANGES
index 23e66d131f9815522636a7c23c4727d2190e6508..98525cec8279a9e1c99e5d99f256173275617c39 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -40,6 +40,7 @@
        #709: Bump lighttpd package to 1.4.24
        #713: Migrate openntpd package to Makefile.autotools.in
        #715: Bump libidn package to 1.15 and other fixes
+       #717: Bump dnsmasq to 2.51 and introduce new IDN option
 
 2009.08, Released August 31th, 2009:
 
index 073f57b3c7cbb988669659e0893c2fce65c64bdd..a8d0d9a6ede5ce2ecd4693ba6aa1cb9366d93c8c 100644 (file)
@@ -20,3 +20,11 @@ config BR2_PACKAGE_DNSMASQ_DHCP
        help
          Enable DHCP server support in dnsmasq.
 
+config BR2_PACKAGE_DNSMASQ_IDN
+       bool "IDN support (BIG!)"
+       depends on BR2_PACKAGE_DNSMASQ
+       select BR2_PACKAGE_LIBINTL
+       select BR2_PACKAGE_LIBIDN
+       help
+         Enable IDN support in dnsmasq.
+         This option is a big space taker since is pulls in many libraries.
index dec2971aad7ef38f4d94389f0136bb96602b92c2..07b3c484adabcda576c6f6ca84d2537b22d464a0 100644 (file)
@@ -4,8 +4,7 @@
 #
 #############################################################
 
-DNSMASQ_VERSION = 2.50
-DNSMASQ_SOURCE = dnsmasq-$(DNSMASQ_VERSION).tar.gz
+DNSMASQ_VERSION = 2.51
 DNSMASQ_SITE = http://thekelleys.org.uk/dnsmasq
 DNSMASQ_AUTORECONF = NO
 DNSMASQ_MAKE_ENV = CC="$(TARGET_CC)" CFLAGS="$(TARGET_CFLAGS)" LDFLAGS="$(TARGET_LDFLAGS)"
@@ -24,6 +23,12 @@ ifneq ($(BR2_PACKAGE_DNSMASQ_TFTP),y)
 DNSMASQ_COPTS += -DNO_TFTP
 endif
 
+ifeq ($(BR2_PACKAGE_DNSMASQ_IDN),y)
+DNSMASQ_MAKE_OPT += all-i18n
+DNSMASQ_DEPENDENCIES += libidn libintl
+DNSMASQ_MAKE_ENV += LDFLAGS+="-lintl"
+endif
+
 ifneq ($(BR2_LARGEFILE),y)
 DNSMASQ_COPTS += -DNO_LARGEFILE
 endif