package/libvirt: fix NLS build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Thu, 19 Aug 2021 07:08:07 +0000 (09:08 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 19 Aug 2021 20:46:42 +0000 (22:46 +0200)
Fix the following build failure raised since the addition of the package
in commit ccfc90e1010e42e6529afae3a5ea8bf7226dabc1:

/tmp/instance-0/output-1/host/opt/ext-toolchain/bin/../lib/gcc/i686-buildroot-linux-uclibc/9.3.0/../../../../i686-buildroot-linux-uclibc/bin/ld: src/util/libvirt_util.a(viralloc.c.o): in function `virInsertElementsN':
viralloc.c:(.text+0x167): undefined reference to `libintl_dgettext'

Fixes:
 - http://autobuild.buildroot.net/results/2349c55a4a42f08ca52700c60cda3065b0c4bd88

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libvirt/libvirt.mk

index b36cf3fb60c4d400e7b24e108cb4e403854c739f..1b420771f56ad8c0d4221cae16fafc5ea69b4ed5 100644 (file)
@@ -21,7 +21,10 @@ LIBVIRT_DEPENDENCIES = \
        libtirpc \
        libxml2 \
        udev \
-       zlib
+       zlib \
+       $(TARGET_NLS_DEPENDENCIES)
+
+LIBVIRT_LDFLAGS = $(TARGET_LDFLAGS) $(TARGET_NLS_LIBS)
 
 LIBVIRT_CONF_ENV += \
        CFLAGS="$(TARGET_CFLAGS) `$(PKG_CONFIG_HOST_BINARY) --cflags libtirpc`" \
@@ -49,6 +52,7 @@ LIBVIRT_CONF_OPTS = \
        -Dinit_script=$(if $(BR2_INIT_SYSTEMD),systemd,none) \
        -Dlogin_shell=disabled \
        -Dnetcf=disabled \
+       -Dnls=$(if $(BR2_SYSTEM_ENABLE_NLS),enabled,disabled) \
        -Dnumad=disabled \
        -Dopenwsman=disabled \
        -Dpciaccess=enabled \