chrony: add optional seccomp support
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 15 Sep 2017 14:24:37 +0000 (16:24 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 20 Sep 2017 17:31:17 +0000 (19:31 +0200)
seccomp support has been available since chrony-2.2

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/chrony/chrony.mk

index 3b10c8cbffdfe9e063d6ed13d8a610500af505e9..e78d4b4857fbe6c7b1379c40c81b10f4fa887373 100644 (file)
@@ -13,7 +13,6 @@ CHRONY_CONF_OPTS = \
        --host-system=Linux \
        --host-machine=$(BR2_ARCH) \
        --prefix=/usr \
-       --without-seccomp \
        --without-tomcrypt
 
 ifeq ($(BR2_PACKAGE_LIBCAP),y)
@@ -28,6 +27,13 @@ else
 CHRONY_CONF_OPTS += --without-nss
 endif
 
+ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
+CHRONY_CONF_OPTS += --enable-scfilter
+CHRONY_DEPENDENCIES += libseccomp
+else
+CHRONY_CONF_OPTS += --without-seccomp
+endif
+
 ifeq ($(BR2_PACKAGE_READLINE),y)
 CHRONY_DEPENDENCIES += readline
 else