SDL_image: fix runtime libjpeg failure
authorBaruch Siach <baruch@tkos.co.il>
Mon, 23 Nov 2009 22:05:23 +0000 (23:05 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 23 Nov 2009 22:05:23 +0000 (23:05 +0100)
By default SDL_image loads libjpeg at runtime on-demand. The find_lib
routine in the configure script of SDL_image searches the /usr/lib directory
of the host machine to find the file name of the jpeg library.

When the host on which Buildroot is being built contains newer version of
libjpeg (e.g.  libjpeg7), the configure script incorrectly uses its file
name. The result is a runtime failure to load libjpeg.

Fix this by disabling runtime load of libjpeg.

[Peter: disable for png+tiff as well]

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/sdl_image/sdl_image.mk

diff --git a/CHANGES b/CHANGES
index 7580e52359414163879aaec2fb6c62009e2551b3..a390c22a79ed651f67b1eb858d751545abf4de2c 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -28,7 +28,7 @@
        libupnp, libuuid, libxml2, lighttpd, ltrace, lua, lzma, magiccube4d,
        matchbox, mdadm, nbd, ncftp, ncurses, netkittelnet, netsnmp,
        ng-spice-rework, ntfs-3g, openntp, openssl, pcmanfm, php, psmisc,
-       python, quagga, radvd, rpm, rsync, rubix, samba, sawman, sdl,
+       python, quagga, radvd, rpm, rsync, rubix, samba, sawman, sdl, sdl_image,
        shared-mime-info, sfdisk, spawn-fcgi, speech-tools, sqlite, squashfs,
        synergy, syslinux, sysklogd, target-binutils, tcpdump, torsmo, u-boot,
        udpcast, util-linux, valgrind, vsftpd, wipe, wpa-supplicant, x11vnc,
index 127a2922b9923ff1f4bb297b2cb58f00188b69c7..772bb8606d5e2e4b3f122786ad2db11c03558fff 100644 (file)
@@ -14,6 +14,9 @@ SDL_IMAGE_CONF_OPT:=--with-sdl-prefix=$(STAGING_DIR)/usr \
                --with-sdl-exec-prefix=$(STAGING_DIR)/usr \
                --disable-sdltest \
                --disable-static \
+               --disable-jpg-shared \
+               --disable-png-shared \
+               --disable-tif-shared \
                --enable-bmp=$(if $(BR2_PACKAGE_SDL_IMAGE_BMP),yes,no) \
                --enable-gif=$(if $(BR2_PACKAGE_SDL_IMAGE_GIF),yes,no) \
                --enable-jpg=$(if $(BR2_PACKAGE_SDL_IMAGE_JPEG),yes,no) \