build: use find -perm /mode, instead of -perm +mode STRIP_FIND_CMD
authorTzu-Jung Lee <roylee17@gmail.com>
Wed, 19 Jun 2013 09:24:50 +0000 (17:24 +0800)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Jul 2013 21:38:17 +0000 (23:38 +0200)
The -perm +mode is deprecated, and sometimes yields suprising results.
It can be confused with permission in symbolic mode, for example '+u+g',
as POSIX spec suggests.

Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index f477124935cff1aaef4a058c7669e2f72a0fa81b..0cd7f5541fd21c79049b8347feddb7cb0a8b8dbf 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -449,7 +449,7 @@ STRIP_FIND_CMD = find $(TARGET_DIR)
 ifneq (,$(call qstrip,$(BR2_STRIP_EXCLUDE_DIRS)))
 STRIP_FIND_CMD += \( $(call finddirclauses,$(TARGET_DIR),$(call qstrip,$(BR2_STRIP_EXCLUDE_DIRS))) \) -prune -o
 endif
-STRIP_FIND_CMD += -type f -perm +111
+STRIP_FIND_CMD += -type f -perm /111
 STRIP_FIND_CMD += -not \( $(call findfileclauses,libpthread*.so* $(call qstrip,$(BR2_STRIP_EXCLUDE_FILES))) \) -print
 
 target-finalize: