gst1-plugins-good: Add support for V4L2 probed devices
authorKieran Bingham <kieran@bingham.xyz>
Wed, 1 Jun 2016 18:11:54 +0000 (19:11 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 3 Jun 2016 13:04:12 +0000 (15:04 +0200)
The V4L2 module of gst-plugins-good provides an extra option to allow
probing for extra devices at plugin load time. This will enable features
such as video conversion using the V4L2 M2M api

Signed-off-by: Kieran Bingham <kieran@bingham.xyz>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gstreamer1/gst1-plugins-good/Config.in
package/gstreamer1/gst1-plugins-good/gst1-plugins-good.mk

index a59033a24ed3e83274e25edd00dac8e3add1b530..95318d9882ab1979083a8b04298a0274f2a98b4d 100644 (file)
@@ -279,6 +279,14 @@ config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_V4L2
 comment "v4l2 needs a toolchain w/ headers >= 3.0"
        depends on !BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_0
 
+config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_V4L2_PROBE
+       bool "v4l2-probe (m2m)"
+       depends on BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_V4L2
+       help
+         Enables the V4L2 probe at plugin load time. This enables
+         support for v4l2 transform devices, such as m2m
+         devices. These plugins are registered as v4l2videoNconvert
+
 config BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_CAIRO
        bool "cairo"
        select BR2_PACKAGE_CAIRO
index 14bd4e8dc793f9eaa6cab4225129da3e4f9f218f..969caa9a2df02d6a86813d22032ed5cea97952ba 100644 (file)
@@ -323,6 +323,12 @@ else
 GST1_PLUGINS_GOOD_CONF_OPTS += --disable-gst_v4l2
 endif
 
+ifeq ($(BR2_PACKAGE_GST1_PLUGINS_GOOD_PLUGIN_V4L2_PROBE),y)
+GST1_PLUGINS_GOOD_CONF_OPTS += --enable-v4l2-probe
+else
+GST1_PLUGINS_GOOD_CONF_OPTS += --disable-v4l2-probe
+endif
+
 ifeq ($(BR2_PACKAGE_XORG7),y)
 GST1_PLUGINS_GOOD_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXv
 GST1_PLUGINS_GOOD_CONF_OPTS += \