erlang-p1-yaml: bump to version 1.0.9
authorJohan Oudinet <johan.oudinet@gmail.com>
Tue, 30 May 2017 14:52:07 +0000 (16:52 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 30 May 2017 21:59:28 +0000 (23:59 +0200)
Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/erlang-p1-yaml/0001-remove-dependencies-from-rebar-config.patch [new file with mode: 0644]
package/erlang-p1-yaml/erlang-p1-yaml.hash
package/erlang-p1-yaml/erlang-p1-yaml.mk

diff --git a/package/erlang-p1-yaml/0001-remove-dependencies-from-rebar-config.patch b/package/erlang-p1-yaml/0001-remove-dependencies-from-rebar-config.patch
new file mode 100644 (file)
index 0000000..facfc2c
--- /dev/null
@@ -0,0 +1,18 @@
+Without this patch, dependencies would be downloaded and compiled
+by rebar at build time.
+
+Signed-off-by: Christophe Romain <cromain@process-one.net>
+
+diff --git a/rebar.config b/rebar.config
+index 68ffdeb..651a829 100644
+--- a/rebar.config
++++ b/rebar.config
+@@ -24,8 +24,6 @@
+ {port_env, [{"CFLAGS", "$CFLAGS"}, {"LDFLAGS", "$LDFLAGS -lyaml"}]}.
+ {port_specs, [{"priv/lib/fast_yaml.so", ["c_src/fast_yaml.c"]}]}.
+
+-{deps, [{p1_utils, ".*", {git, "git://github.com/processone/p1_utils", {tag, "1.0.7"}}}]}.
+-
+ {clean_files, ["c_src/fast_yaml.gcda", "c_src/fast_yaml.gcno"]}.
+
+ {cover_enabled, true}.
index 0e11e45003e2595c77f27f7c33ab22c754007b18..5b8956d7b5f1f16057aad6f5294fd33afbd3ba6f 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 8eaaddda056f1ebb515a5456ba2be855e5b71b9b6eb35788527f39c6600ac6b4 erlang-p1-yaml-1.0.0.tar.gz
+sha256 bf225023168873affd2c67a2ce5c6c81c3db0c7df4f0caa113f23770c7b04e05 erlang-p1-yaml-1.0.9.tar.gz
index 22fcda43f8624c337b437c9b86b3b4d32a1e1825..d8865e0d4286e858bd78afe06b16469af840333a 100644 (file)
@@ -4,10 +4,10 @@
 #
 ################################################################################
 
-ERLANG_P1_YAML_VERSION = 1.0.0
-ERLANG_P1_YAML_SITE = $(call github,processone,p1_yaml,$(ERLANG_P1_YAML_VERSION))
+ERLANG_P1_YAML_VERSION = 1.0.9
+ERLANG_P1_YAML_SITE = $(call github,processone,fast_yaml,$(ERLANG_P1_YAML_VERSION))
 ERLANG_P1_YAML_LICENSE = Apache-2.0
-ERLANG_P1_YAML_LICENSE_FILES = COPYING
+ERLANG_P1_YAML_LICENSE_FILES = LICENSE.txt
 ERLANG_P1_YAML_DEPENDENCIES = libyaml erlang-p1-utils
 
 $(eval $(rebar-package))