libsepol: new package
authorClayton Shotwell <clshotwe@rockwellcollins.com>
Wed, 11 Sep 2013 21:59:21 +0000 (16:59 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 20 Sep 2013 13:34:41 +0000 (15:34 +0200)
[Peter: white space fixes]
Signed-off-by: Clayton Shotwell <clshotwe@rockwellcollins.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/libsepol/Config.in [new file with mode: 0644]
package/libsepol/libsepol.mk [new file with mode: 0644]

index e187aa3e4ad239258db49889087faa0dac35aeba..c3725f2ab529704f21c7cbe30ad8825d624446c0 100644 (file)
@@ -694,6 +694,10 @@ source "package/liblog4c-localtime/Config.in"
 source "package/tzdata/Config.in"
 endmenu
 
+menu "Security"
+source "package/libsepol/Config.in"
+endmenu
+
 menu "Text and terminal handling"
 source "package/enchant/Config.in"
 source "package/libfribidi/Config.in"
diff --git a/package/libsepol/Config.in b/package/libsepol/Config.in
new file mode 100644 (file)
index 0000000..f92af52
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_LIBSEPOL
+       bool "libsepol"
+       help
+         Libsepol is the binary policy manipulation library. It doesn't
+         depend upon or use any of the other SELinux components.
+
+         http://selinuxproject.org/page/Main_Page
diff --git a/package/libsepol/libsepol.mk b/package/libsepol/libsepol.mk
new file mode 100644 (file)
index 0000000..4140ed3
--- /dev/null
@@ -0,0 +1,48 @@
+################################################################################
+#
+# libsepol
+#
+################################################################################
+
+LIBSEPOL_VERSION = 2.1.9
+LIBSEPOL_SITE = http://userspace.selinuxproject.org/releases/20130423/
+LIBSEPOL_LICENSE = LGPLv2.1+
+LIBSEPOL_LICENSE_FILES = COPYING
+
+LIBSEPOL_INSTALL_STAGING = YES
+
+define LIBSEPOL_BUILD_CMDS
+       # DESTDIR is needed during the compile to compute library and
+       # header paths.
+       $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) DESTDIR=$(STAGING_DIR)
+endef
+
+define LIBSEPOL_INSTALL_STAGING_CMDS
+       $(MAKE) -C $(@D) install $(TARGET_CONFIGURE_OPTS) DESTDIR=$(STAGING_DIR)
+endef
+
+define LIBSEPOL_INSTALL_TARGET_CMDS
+       $(MAKE) -C $(@D) install $(TARGET_CONFIGURE_OPTS) DESTDIR=$(TARGET_DIR)
+endef
+
+define LIBSEPOL_CLEAN_CMDS
+       $(MAKE) -C $(@D) clean
+endef
+
+define HOST_LIBSEPOL_BUILD_CMDS
+       $(MAKE) -C $(@D) $(HOST_CONFIGURE_OPTS) DESTDIR=$(HOST_DIR)
+endef
+
+define HOST_LIBSEPOL_INSTALL_CMDS
+       $(MAKE) -C $(@D) install $(HOST_CONFIGURE_OPTS) DESTDIR=$(HOST_DIR)
+       mv $(HOST_DIR)/lib/libsepol.so.1 $(HOST_DIR)/usr/lib
+       (cd $(HOST_DIR)/usr/lib; rm -f libsepol.so; ln -s libsepol.so.1 libsepol.so)
+       -rmdir $(HOST_DIR)/lib
+endef
+
+define HOST_LIBSEPOL_CLEAN_CMDS
+       $(MAKE) -C $(@D) clean
+endef
+
+$(eval $(generic-package))
+$(eval $(host-generic-package))