package/coreutils: introduce a host variant
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 18 Dec 2019 20:39:03 +0000 (21:39 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 6 Jan 2020 20:36:45 +0000 (21:36 +0100)
More and more packages are now depending on ln --relative, some require
realpath, both of which only got introduced in "recent" versions of
coreutils; older distros had a separate realpath, though, but that is
not in the list of our required dependencies, and was not installed by
default.

So, we introduce a minimal host variant of coreutils to provide those
programs.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/coreutils/coreutils.mk

index d312197e7edc4cfede45cddb40165e5375b6ef92..a8137d168711d0e596464330597ba41d810f4a66 100644 (file)
@@ -148,4 +148,18 @@ endef
 endif
 COREUTILS_POST_INSTALL_TARGET_HOOKS += COREUTILS_FIX_CHROOT_LOCATION
 
+# Explicitly install ln and realpath, which we *are* insterested in.
+# A lot of other programs still get installed, however, but disabling
+# them does not gain much at build time, and is a loooong list that is
+# difficult to maintain...
+HOST_COREUTILS_CONF_OPTS = \
+       --disable-acl \
+       --disable-libcap \
+       --disable-rpath \
+       --disable-single-binary \
+       --disable-xattr \
+       --without-gmp \
+       --enable-install-program=ln,realpath
+
 $(eval $(autotools-package))
+$(eval $(host-autotools-package))