uclibc: enable parallel building of libraries
authorAlexey Brodkin <Alexey.Brodkin@synopsys.com>
Fri, 27 Jun 2014 16:26:00 +0000 (20:26 +0400)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Jun 2014 11:20:07 +0000 (13:20 +0200)
The use of MAKE1 for uClibc dates back 10 years:

commit 8e5fb3fb4ab09b4dc04fe7cb3f7becce6514117b
Author: Eric Andersen <andersen@codepoet.org>
Date:   Sat Dec 11 13:01:10 2004 +0000

    Add initial BR2_JLEVEL support, with some exceptions for apps that
    have broken 'make -j' support

Since that time there were lots of improvements in uClibc that seem to allow
parallel building of libs finally.

Unfortunately uClibc tests have dependences on previously built files,
that's why tests left with MAKE1.

Signed-off-by: Alexey Brodkin <abrodkin@synopsys.com>
Cc: Anton Kolesov <akolesov@synopsys.com>
Cc: Peter Korsgaard <peter@korsgaard.com>
Cc: Gustavo Zacarias <gustavo@zacarias.com.ar>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/uclibc/uclibc.mk

index 70705a200171f641bee25d0b8a96da4dc6b711d7..8337bb6f847f9994e267aa41b66a9ccc78d84fb4 100644 (file)
@@ -482,13 +482,13 @@ endef
 endif
 
 define UCLIBC_BUILD_CMDS
-       $(MAKE1) -C $(@D) \
+       $(MAKE) -C $(@D) \
                $(UCLIBC_MAKE_FLAGS) \
                PREFIX= \
                DEVEL_PREFIX=/ \
                RUNTIME_PREFIX=/ \
                all
-       $(MAKE1) -C $(@D)/utils \
+       $(MAKE) -C $(@D)/utils \
                PREFIX=$(HOST_DIR) \
                HOSTCC="$(HOSTCC)" hostutils
        $(UCLIBC_BUILD_TEST_SUITE)