perl-net-ssh2: add missing dependency on zlib
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Mon, 23 Jul 2018 20:06:26 +0000 (22:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 25 Jul 2018 21:02:45 +0000 (23:02 +0200)
perl-net-ssh2 requires zlib. When using the openssl backend to libssh2, this
dependency is implicit via openssl, but when using the libgcrypt backend the
dependency is missing.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/perl-net-ssh2/Config.in
package/perl-net-ssh2/perl-net-ssh2.mk

index 07c42ee5b1a449e9d39d1be9cd65a20a9a3f2787..8f359b701567b0050b56f4ed08beee391d4509d1 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_PERL_NET_SSH2
        bool "perl-net-ssh2"
        depends on !BR2_STATIC_LIBS
        select BR2_PACKAGE_LIBSSH2
+       select BR2_PACKAGE_ZLIB
        help
          Support for the SSH 2 protocol via libssh2.
 
index 6d84deb284255eedbacec8f5c587d9969d9d5b28..b174fa62108980b872ebc3da716c81a48fd171df 100644 (file)
@@ -9,6 +9,6 @@ PERL_NET_SSH2_SOURCE = Net-SSH2-$(PERL_NET_SSH2_VERSION).tar.gz
 PERL_NET_SSH2_SITE = $(BR2_CPAN_MIRROR)/authors/id/S/SA/SALVA
 PERL_NET_SSH2_LICENSE = Artistic or GPL-1.0+
 PERL_NET_SSH2_LICENSE_FILES = README
-PERL_NET_SSH2_DEPENDENCIES = libssh2
+PERL_NET_SSH2_DEPENDENCIES = libssh2 zlib
 
 $(eval $(perl-package))